Solved: Tor always in restarting normal?

TOR always shown as restarting - is this normal running latest umbrel on ubuntu. Node seems to work channel active. Honesly never checked the docker status since running now I am curious if tor should always be in restarting state?

IMAGE                                           STATUS                           NAMES
getumbrel/tor:0.4.7.8                           Restarting (1) 11 seconds ago    lightning-shell_tor_server_1
ghcr.io/ibz/lightning-shell:v0.1.10-buster-slim Up 12 hours                      lightning-shell_web_1
getumbrel/tor:0.4.7.8                           Restarting (1) 9 seconds ago     lightning_tor_1
getumbrel/tor:0.4.7.8                           Restarting (1) 7 seconds ago     lightning_tor_server_1
getumbrel/tor:0.4.7.8                           Restarting (1) 29 seconds ago    bitcoin_tor_1
getumbrel/tor:0.4.7.8                           Restarting (1) 10 seconds ago    bitcoin_tor_server_1
getumbrel/tor:0.4.7.8                           Restarting (1) 22 seconds ago    uptime-kuma_tor_server_1
getumbrel/tor:0.4.7.8                           Restarting (1) 21 seconds ago    lndg_tor_server_1
getumbrel/tor:0.4.7.8                           Restarting (1) 31 seconds ago    electrs_tor_server_1
getumbrel/tor:0.4.7.8                           Restarting (1) 30 seconds ago    electrs_tor_1
getumbrel/tor:0.4.7.8                           Restarting (1) 43 seconds ago    tor_server
getumbrel/tor:0.4.7.8                           Up 12 hours                      tor_proxy

all I could find in logs is (similar for all app above):

Dec 28 20:02:10.338 [notice] Tor 0.4.7.8 running on Linux with Libevent 2.1.12-stable, OpenSSL 1.1.1n, Zlib 1.2.11, Liblzma N/A, Libzstd N/A and Glibc 2.31 as libc.
Dec 28 20:02:10.338 [notice] Tor can't help you if you use it wrong! Learn how to be safe at https://support.torproject.org/faq/staying-anonymous/
Dec 28 20:02:10.338 [notice] Read configuration file "/tmp/torrc".
Dec 28 20:02:10.340 [warn] Permissions on directory /data/app-electrs are too permissive.
Dec 28 20:02:10.340 [warn] Failed to parse/validate config: Failed to configure rendezvous options. See logs for details.
Dec 28 20:02:10.340 [err] Reading config failed--see warnings above.

Think problem is solved - only the running tor user should have access. to the app dirs (chmod 700).
Sometimes it helps to write down things and sort the thoughts :slight_smile: