[SOLVED] Tailscale not starting

I just updated Umbrel to latest version 0.4.14 and wanted to test Tailscale.
I have a NUC with DebianOS (not UmbrelOS on Raspi).
Installation went smooth, tailscale installed, but is never ending “starting”.

I used months ago Tailscale on my Umbrel but installed as a separate app. Worked, tested but then I remove it.

Now I see it in Umbrel app and wanted to give it a try again.

Here are some logs of Tails:

web_1  | logpolicy.Read /var/lib/tailscale/tailscaled.log.conf: open /var/lib/tailscale/tailscaled.log.conf: no such file or directory
web_1  | 2022/02/10 11:14:24 wgengine.NewUserspaceEngine(tun "userspace-networking") ...
web_1  | 2022/02/10 11:14:24 dns: using dns.noopManager
web_1  | 2022/02/10 11:14:24 link state: interfaces.State{defaultRoute=enp3s0 ifs={br-7c19b0686c1e:[] docker0:[] enp3s0:[]} v4=true v6=false}
web_1  | 2022/02/10 11:14:24 magicsock: disco key = d:57c6196715723942
web_1  | 2022/02/10 11:14:24 Creating wireguard device...
web_1  | 2022/02/10 11:14:24 Bringing wireguard device up...
web_1  | 2022/02/10 11:14:24 Bringing router up...
web_1  | 2022/02/10 11:14:24 Clearing router settings...
web_1  | 2022/02/10 11:14:24 Starting link monitor...
web_1  | 2022/02/10 11:14:24 Engine created.
web_1  | 2022/02/10 11:14:24 logtail: dialed "log.tailscale.io:443" in 219ms
web_1  | 2022/02/10 11:14:24 netmap packet filter: (not ready yet)
web_1  | 2022/02/10 11:14:24 Start
web_1  | 2022/02/10 11:14:24 using backend prefs
web_1  | 2022/02/10 11:14:24 created empty state for "_daemon": Prefs{ra=true dns=true want=false routes=[] nf=on Persist=nil}
web_1  | 2022/02/10 11:14:24 got initial portlist info in 0s
web_1  | 2022/02/10 11:14:24 control: HostInfo: {"IPNVersion":"1.20.2-t8e643357d","BackendLogID":"339fc5157a09e0a97e852c7ebca638d7515e54e57756f12bcb24cd4f5a9aefe3","OS":"linux","OSVersion":"Alpine Linux v3.15; kernel=4.19.0-18-amd64; container","Hostname":"node","GoArch":"amd64","Services":[{"Proto":"tcp","Port":22},{"Proto":"tcp","Port":80},{"Proto":"tcp","Port":2100,"Description":"tailscale"},{"Proto":"tcp","Port":3000},{"Proto":"tcp","Port":3001},{"Proto":"tcp","Port":3002},{"Proto":"tcp","Port":3007},{"Proto":"tcp","Port":3008},{"Proto":"tcp","Port":7070},{"Proto":"tcp","Port":7681},{"Proto":"tcp","Port":8008},{"Proto":"tcp","Port":8080},{"Proto":"tcp","Port":8088},{"Proto":"tcp","Port":8089},{"Proto":"tcp","Port":8333},{"Proto":"tcp","Port":8889},{"Proto":"tcp","Port":9735},{"Proto":"tcp","Port":10009},{"Proto":"tcp","Port":50001}]}
web_1  | 2022/02/10 11:14:24 Backend: logs: be:339fc5157a09e0a97e852c7ebca638d7515e54e57756f12bcb24cd4f5a9aefe3 fe:
web_1  | 2022/02/10 11:14:24 control: authRoutine: state:new; goal=nil paused=false
web_1  | 2022/02/10 11:14:24 Switching ipn state NoState -> NeedsLogin (WantRunning=false, nm=false)
web_1  | 2022/02/10 11:14:24 blockEngineUpdates(true)
web_1  | 2022/02/10 11:14:24 health("overall"): error: state=NeedsLogin, wantRunning=false
web_1  | 2022/02/10 11:14:24 control: mapRoutine: state:new
web_1  | 2022/02/10 11:14:24 wgengine: Reconfig: configuring userspace wireguard config (with 0/0 peers)
web_1  | 2022/02/10 11:14:24 wgengine: Reconfig: configuring router
web_1  | 2022/02/10 11:14:24 wgengine: Reconfig: configuring DNS
web_1  | 2022/02/10 11:14:24 dns: Set: {DefaultResolvers:[] Routes:{} SearchDomains:[] Hosts:0}
web_1  | 2022/02/10 11:14:24 dns: Resolvercfg: {Routes:{} Hosts:0 LocalDomains:[]}
web_1  | 2022/02/10 11:14:24 dns: OScfg: {Nameservers:[] SearchDomains:[] MatchDomains:[]}

@mayank or @lukechilds do you think it doesn’t like it my setup or it just hung the docker repository?
How could I stop the starting and restart again the tailscale service ? Or only a full restart of the node can fix it?
Is it something I missed?

It looks like Tailscale is running ok but just the web ui isn’t accessible. Do you have something already running on port 2100 on the host?

As a last resort, without access to the web ui you should be able to complete Tailscale setup by running ~/umbrel/scripts/app compose tailscale exec web tailscale up. I think it’ll dump a URL that you can visit to complete the pairing process.

1 Like

LOL I am such a noob. No it wasn’t anything on that port.
But I just added in ufw the port 2100 and now I can open the web on local IP:2100.
Is asking to login to Tailscale. So I supposed just using the previous account is just fine and follow the steps.
Thanks for the hint.

Awesome, glad you got it sorted!

1 Like

BOOOM! Connected!
Just tested Zeus to connect to my node using Tailscale VPN IP.
Works perfect!
Do you think it should work also for other apps like LNbits (yes, I should have the ports open, I suppose)?

THIS IS THE WAY! Damn is so simple to connect.

Yeah it works for all apps. Even apps we couldn’t connect before over Tor e.g Breez can now use your node as a trrusted Neutrino source.

Also, if you enable magic DNS in the Tailscale admin you can refer to your Umbrel by it’s hostname (umbrel) instead of it’s Tailscale IP on all your other Tailscale connected devices.

I have a private domain and static public IP, maybe I could play with these… interesting.