Socks5() general failure - bitcoin sync hangs up

Hi @all !

I have a strange issue.

Every round about 8h my node hang up while syncing.

At this point, only restarting (whats takes more time than usual in this case) get’s the node back working.

I run Umbrel 0.3.10 on Ubuntu 20.04.2 LTS … does maybe my tor hang up, so that bitcoin lose its connection?

Thank you for every response

Few days ago I also had my node (on Debian) making funny things because of Tor. But the logs in bitcoind was OK.

Run docker-compose logs tor to see something funny in Tor.

Also if you edit your lnd.conf file, be sure it was edited OK, sometimes spaces can messup.
Don’t restart immediately, wait a bit longer. Sometimes gets it.
Patience is a the key for a node operator.

Is this normal LND behaviour?

the Node was stuck for 8h and more when the socks5 issue came up.

i reinstalled docker-ce now, in doubt that it worked properly

happened again. meanwhile i reinstalled docker-ce. thought that it fixed it.

but now it’s stuck again. the webUi doesn’t get any informations too, but the login process works


It was a memory issue. 4gb RAM where running full, and the existing swap file was located on an HDD.

Reaching the RAM limit resulted in heavy I/O Rates and slowed down the whole system , until sudden death.

deactivating swap resulted in a new level of performance.

now with a swap file located on an different ssd, the whole system runs stable and fast.

1 Like