RPI media server

Facundo Apellido:
Hey there guys.
I’ve been struggling to make umbrel work fine as a media server.
I’m on a RPI 4 4gb.
I have a quite old 100 mb/s router, but it doesn’t seem to be the problem, according to documentation.
I’ve been able to successfully use the arr ecosystem, but not being really able to play or cast movies on my TV.
I tried with plex app on smart tv but most movies buffer constantly. I also tried with plex app on my phone casting to Chromecast and the same problem.
If I play movies directly from webui in any of the PCs it works just fine.
Some really heavy movies sometimes work fine, and some low quality ones sometimes take ages to buffer and keep buffering.
I tried applying conversion and without and problems persist.
Then I tried jellyfin, but the server never ‘sees’ Chromecast device.
Cellphone app does but movies won’t stream to Chromecast.

Is it a problem in my setup? Should I move to a faster router, or better hardware?

To answer in advance, obviously Chromecast wasn’t with a wired connection, but TV is. Still no luck.

It’s hard to say with certainty what the causes here might be, but here’s my experience and what I know about media server set-ups.

I use jellyfin/plex, and while they are great apps, one issue I have also experienced is the bugginess of chromecasting from those apps. I often have to use Chrome’s ‘stream tab’ feature instead, and I believe this is mostly to do with plex/jellyfinds implementation of casting.

In terms of buffering, this could be a combination of your network and the Pi 4’s performance. Sometimes Chromecasting requires transcoding on-the-fly which is pretty intensive and would cause buffering on a Pi 4 CPU with only 4GB RAM. Also the network may be a limitation for chromecasting if the TV doesn’t use a wired connection to your router.

After deep analyzing the case, I realised that transcoding in plex is the problem. Even with OC settings it is too much for RPI4.
The good thing is that after a lot of searching I found a solution to be able to cast with jellyfin.
You need to have the cell app since Jellyfin running on umbrel access through browser, never sees my chromecast.
In the app you have to configure your server and to be able to cast you should go to settings>playback>google cast version = unstable.
RPI 4 is enough for Jellyifin’s transcoding. Quality is not great, but more than ok.
Also, if I want to watch a movie in great quality, in Plex you can transcode it before watching it, for the best quality available to your device. That being the case, RPI 4 is more than enough for playback even in 4k movies.
Thanks for all the answers.

Good to hear. Yeah very similar to the experience I had.