Repeated 0.5.0 Upgrade failures: tried reflash of SD

I’ve tried upgrading via the UI… it goes through all the motions and the logs look like it did stuff but it comes back up and its still 0.4.18.

I’ve tried re-flashing the SD card (and then having to add back my SSH key from my main computer).

It turns on back in 0.4.18 and after at least a couple of attempts to upgrade via the UI and a few restarts, nothing has happened.

I’ve gone looking for any software I installed by hand (there was an early version of the Podcast V4V app Helipad that I helped dev on) but I’ve removed all reference to that.

Any other suggestions on kicking this thing forward?

1 Like

Glad it’s not just me! :slight_smile:

The same hapeened to me, but after a 3rd attempt I get the red umbrella and Error: System service failed :frowning:

1 Like


1 Like

same :neutral_face:

This solved the problem:

umbrel@umbrel:~ $ rm umbrel/statuses/update-in-progress
umbrel@umbrel:~ $ sudo systemctl restart umbrel-startup

This helped me!
rm -f ~/umbrel/statuses/update-in-progress && sudo reboot