Tried updating to 0.5.0 but still shows 0.4.18

I tried updating to 0.5.0 by flashing it because the update notification wasn’t originally appearing and kept saying 0.4.18 was the current version under check update. After flashing my sd card with 0.5.0, it still shows version 0.4.18. In the troubleshoot logs it says umbrel version 0.4.18 but flashed version is 0.5.0. Any ideas on what’s going on and why 0.5.0 isn’t work?

1 Like

Also its saying it can’t update docker when I try to update manually via ssh.

1 Like

Seems similar to what I am experiencing:

Yea I saw your post. I tried updating docker manually via ssh but get back this
W: Failed to fetch The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 7EA0A9C3F273FCD8

I’m having the same problem. Just updated to 0.4.18 and after that I tried updating to 0.5 but ended with a Docker error.
Tried rebooting but it’s the same

Today I logged in to Umbrel and it was on version 0.5


I don’t know how it happened, because I restarted it after trying to update so it wasn’t a restart what triggered the new version. Perhaps the web connection to it… I don’t know