Reboot and select a proper Boot device

I’m encountering a bizarre issue with the new 1.1 update while using the USB guide to create a bootable device. I successfully installed Umbrel on my SSD within an Asus mini PC, and everything works perfectly until I try to reboot. Despite my efforts with various BIOS settings, the device won’t boot from the SSD, even though it previously ran Debian on the same disk.

Strangely, when I connect the SSD externally via a USB adapter, it boots without any issues. I don’t understand why this is happening, and I prefer not to run my internal disk externally, it makes no sense.

Should I just wait for an update? My BIOS hasn’t been updated since 2018, and I’m already on the latest firmware.

1 Like

thanks for your quick attempt to help me, i don’t find that option on my BIOS, this version is from 2018 maybe its to old, or maybe its asus and does not have that option

i already tried multiple things inside this options, without any luck…

i even tried changing this advanced option, from AHCI to IDE or disabled…

I am using a ASRock A520M-HDV. I only stumbled upon it because after I failed installing umbrel I wanted to install one that focused on virtual computers and I was having similar issues when installing that os. I looked around their support and they talked about optimizing my BIOS settings for virtualization. I also have CSM off and use AHCI

I’m really grateful for the help, but unfortunately, it didn’t work. It’s possible that my BIOS doesn’t support this, which is really disappointing. I would love to continue using Umbrel, but I may need to look for alternatives if the team can’t provide support for this issue.

1 Like

Same Problem with a Fujitsu Futro S740, Intel J4105, 4GB Ram, 256GB M.2 SSD, (AMI Bios V5x, 9/2022).
The system was running previously on Ubuntu Server and Umbrel 5.4 perfectly.
I did the backup of umbrel 5.4, booted from USB and installed Umbrel 1.x.
At 1st boot no Boot device was detected.
This is anoying because now I’ve a broken system and cannot revert back!

Even it is not possible to get it to run on Hyper-V. I was not able to boot from img nor convert it to an *.iso with different tools (CLI & GUI). Hence I descided to give it a try on the Futro…

I was able to work this around by installing rEFInd

For those encountering difficulties booting Umbrel, here are two alternative solutions based on different scenarios:

Option A: If you can connect your drive externally and boot from there, follow these steps:

  1. Boot your computer from the external drive.
  2. Inside Umbrel, navigate to Settings → Advanced Settings → Terminal.
  3. Type the following command in the terminal:
sudo apt install refind

Option B: If you can’t boot the device even using an external drive reader, follow these steps:

  1. Watch this video guide to learn how to install Ubuntu or Windows onto the drive: Install Ubuntu/Windows Video Guide.
  2. Create a partition to install Umbrel.
  3. You’ll be able to switch between operating systems using rEFInd.

Fastest auto boot
In my specific case, I only have one bootable OS, which is Umbrel. Therefore, I want it to boot as fast as possible without needing to select the OS. Here’s how you can achieve this:

  1. Open your Umbrel terminal as shown before.
  2. Enter the command:
cd /boot/efi/EFI/refind/
sudo nano refind.conf
  1. Change the default timeout from 20 to 1 in the file.
  2. Save the file (Ctrl+X).
  3. Now, your device will automatically select the OS in 1 second.

This adjustment should streamline the boot process for your Umbrel device.


This fixed! thanks

1 Like

test my solution, it will work just great, try to connect your drive externally first, so you can access umbrel and open the umbrel terminal, then install refind and reboot, boom, its done

1 Like

Many thanks @Nirvana
The problem is that I don’t have an adapter yet to connect the M.2 SSD externally.
I was able to solve it for myself in a different way and have created a separate article for it:

FYI, during troubleshooting while connected to SSH, I also tried the refind install, but that didn’t solve the problem for me.

1 Like