Problems accessing umbrel Bitcoin node

I’ve bought a raspberry pi node and installed umbrel software on it. Connected to WiFi modem thru a network cable. Every thing seems to work hardware-vise, until I try to access the node thru http://umbrel.local or http://umbrel, or thru the angry IP-scanner. Every time and in every browser I get the error: ERR_CONNECTION_REFUSED. Tried on two different computers and on my cellphone. Tried connecting directly to the modem with cable, same error. Tried disabling fire wall and antivirus, same error. Can anyone help me? I’ve really looked forward to getting this node, and it is disappointing that it doesn’t work. Tried troubleshooting for hours. I’m not the most technical, so please write solutions in a simple manner. My friends built it the same way and it works for them. Thank you for helping! Best regards, Fredrik, Norway

1 Like

Hi there, TheOak. I am by no means an expert on bitcoin, nodes, or Umbrel specifically. I was just in the same boat as you. I bought all the hardware Umbrel’s guide says to get and connect with each other. I couldn’t bring up the umbrel page with my URL on my personal laptop. I assumed you were supposed to plugged a screen into the Raspberry Pi, and when I finally read that you can initialize/interface with the Umbrel software with any device connected to the same internet network, I was really impressed and excited. Long story short it was disappointing (just as you are expressing) when I couldn’t connect to it. I was so frustrated and determined, I actually took a big leap of faith (of myself) and followed some advice on the Umbrel Telegram group regarding using the command prompt, coding program on my laptop. (I hadn’t ever used commands before). I was shocked, first that I actually used and was successful in using the command screen, but also that I was able to determine that my laptop could in fact recognize the Umbrel Node in the Raspberry Pi. I ran the debug code, and it spit a result back at me. I didn’t/don’t know what it was trying to say in all entirety, and I wasn’t able to get any insight from the telegram. The debug result said something about how the ssd wasn’t connecting properly, causing the who thing to not work. So I sat there and thought “shit, Im out here with just me, some insight, and no customer service (hahaha)”. Just two days ago. I unplugged everything, took the micro sd card out, erased what I put on there, reflashed the Umbrel OS, plugged the micro sd card in first, then the ssd via usb, then the ethernet cable, then the usb-c cable (turning everything on (I did it in this very order, as the Umbrel instructions says exactly).

One thing I did get as good advice from the telegram group was that I needed to connect my laptop with an ethernet cable too (not on wifi, at least initially, idk). So while you are waiting the five minutes for the Umbrel OS to boot, connect your personal computer up with ethernet.

I did all of this two days ago after struggling with those same results you are currently facing. I plugged in the umbrel URL into my browser and it worked (well at least I didn’t get a cannot connect screen). The umbrel screen loads for a second, then it brings you to a page where you enter a name, then a password. Unfortunately this is as far as I got, because I wasn’t able to it enter after choosing a password. The button just didn’t do anything. And I am at a loss with that. Its pretty comical really. Anyone have advice on this?

Hi noahmingus. Thanks for your reply. I tried re innstaling everything like you suggested, and connecting with ethernetcable, still getting the samme error: ERROR_CONNECTION_REFUSED, or DNS_PROBE_FINISHED_NXDOMAIN. Im wondering if it’s my internettprovider thats the problem. I’ll try sending them a e-mail. If anyone else has any suggestions, feel free to reply. Thanks.

I have been running an Umbrel node for months and the recent update has broken it. I to get the “ERR_CONNECTION_REFUSED” error, even after a format and fresh install.
I can ssh into it but cannot connect via IP…

how do we fix this?

1 Like

my Umbrel also crapped out after the most recent update :frowning:

Seems to have happed to a lot of people on Reddit too…and still no word from the devs…

Hopefully they are looking in to it and will release a patch soon. They surely can’t ignore the fact that many of us were running our nodes without any issues for months until the latest update.

Link to a post a made about my issue for what it is worth:

Same story, “ERR_CONNECTION_REFUSED”, can’t connect via IP, I can SSH into it. Reflashed the SD card, was able to access the dashboard for about 10 minutes and then “ERR_CONNECTION_REFUSED” again.

Anyone got a fix yet?!

Hi! No, I gave up for now. Node is blinking and everything, but stil error connection refused. Any official feedback from umbrel yet?

1 Like

Does your node stop syncing as well? I can access the dashboard for a couple of hours, then it stops working and the node stops syncing. I have to unplug and plug in the power cable in order for the node to start syncing the blockhain again. I can reach the node via shh the whole time. I used the debugging script but it can’t find any errors

I’ve never been able to get pass “error connection refused”. Tried everything. So disappointing.

1 Like

Try connecting by http://umbrel.localdomain or via IP address. Should work.
It depends on your network. angry ip scanner should tell you


Hi everybody!

After a lot of trying and failing, I finally got the node to work. Not sure what the problem was, but the solution came after talking to support here at umbrel. Using the command function in Windows, typing;
ssh -t umbrel@umbrel.local with either your dashboard password if you had one or moneyprintergobrrr as password when you’re asked for it. Then once you are connected, run the debug script with the following command: ~/umbrel/scripts/debug --upload

The info-file I then got was shared with the umbrel support team. In response to this they gave me another command to enter in the command function; sudo systemctl stop umbrel-startup.service && docker system prune --force --all && sudo systemctl start umbrel-startup.service, same password as before: moneyprintergobrrr

After this it suddenly works! A happy Bitcoiner I am. Good luck to all!

1 Like

Thanks for this one. It didn’t fix it directly with it, but it helped a lot to troubleshoot further.

When I run:
sudo systemctl stop umbrel-startup.service && docker system prune --force --all && sudo systemctl start umbrel-startup.service

I got this error response:
Error response from daemon: failed to prune build cache: file resize error: truncate /var/lib/docker/buildkit/containerdmeta.db: read-only file system

And this helped me to fix it:

Step 1: Disable Umbrel boot:
sudo systemctl disable umbrel-startup && sudo systemctl disable umbrel-connection-details && sudo systemctl disable umbrel-external-storage && sudo systemctl disable umbrel-external-storage-sdcard-update && sudo reboot

Step 2: SSH again.

Step 3: Try to fix the files: sudo fsck -y /dev/sda1

Step 4: sudo systemctl enable umbrel-startup && sudo systemctl enable umbrel-connection-details && sudo systemctl enable umbrel-external-storage && sudo reboot


I had this last problem too, initially - I couldn’t get past creating the username/password combination - the “next” button or whatever wouldn’t work). It turned out that my password wasn’t long / strong enough - I kept changing / lengthening it, to a surprisingly long alphanumeric string, and then suddenly the “next” button came alive and I could click through and continue. No error message, no “your password isn’t strong enough” - just an inactive button vs. an active one.

Don’t know if you’re still stuck there, but worth trying a longer password if you are, until the button “comes alive”.

Now on to figure out why I don’t have a command prompt on the screen that is physically attached to my Umbrel RPi…