Pi Hole setup and issues with Umbrel

Ive been having all sorts of weird issues ever since trying to use Pihole.

  1. It was causing mempool app to not load when clicked. This is due to some issue with my DNS being directed at the Pi 4 IP. changing back to dynamic made this issue go away.

  2. youtube was stuck with restricted mode on. changing back to dynamic fixed this as well.

  3. MOST of the ads were getting through any due to forwarding from the DNS like google or cloudfare.

Does anyone have a good understanding of how to operate the Pihole from the umbrel platform bc at this point ive just uninstalled it.


Hey, sorry to hear you’re having issues. Unfortunately I’m not able to recreate your issue, I’m enabling Pi-hole on my MacBook via pointing my Mac’s DNS at the Umbrel’s IP using this method here: https://discourse.pi-hole.net/t/how-do-i-configure-my-devices-to-use-pi-hole-as-their-dns-server/245#setup-11

I tested both the Mempool Umbrel app and YouTube and both are working well for me without ads. I also tried browsing a few news websites that normally contain lots of ads and they were successfully blocked.

Are you using a different method to enable Pi-hole? Are you adding the Umbrel IP to your computer or in your router settings?

Are you able to provide step by step instructions on how I can replicate your setup to see if I can recreate your issue?



Thanks for the reply Luke, ill look through this. My issue with the Pi-hole was that alot of ads were being forwarded through the Upstream DNS server. <-- this was in the settings tab of pi-hole. there is an option for custom upstream DNS, is this where I put my pi-hole IP address as well? I tried to find resources about how to stop this but it was out of my depth of understanding.

im going to reinstall pihole and see if the mempool app works when i click on it.

ill keep yall posted!

are u using the pihole ip for the upstream?

1 Like

are u guys having luck with youtube apps (on iphone), that still can show the ads if I’m not wrong. but it does work for the web browsers on my mac.

1 Like

Well most of my issues are gone now! I did all the same steps as i had before setting up the pi-hole and it seesm to be working well. Note im using OpenDNS as the upstream servers as well which are the ones recommended by p-hole.

Thanks for looking into it Lukechilds!!

1 Like

Does anyone know of an easy way to reset the PiHole back to original adlist blocking without uninstalling/reinstalling?

I should’ve saved a backup when I first installed it, I know.

When on the mobile app, thumbnails of YouTube posts don’t show up, but thumbnail images of various videos do. Unfortunately, ads still get as well.

I wish there was a series of tutorials on each app in Umbrel. I’ve seen some out there, but they are not from within the Umbrel OS.

EG: the documentation within PiHole references the CLI, yet how to get to the CLI is perplexing.

“a noob’s gotta learn what a noob’s gotta learn”

Just delete all the adlists that you have added and update gravity.
This is the default https://raw.githubusercontent.com/StevenBlack/hosts/master/hosts

Thank you @nycholas, done.

I just wish there was a good list that blocked YouTube on my phone app. Brave browser does an excellent job, I just wish I could get PiHole to follow suit.

I’m trying to achieve the same with YT ads, apparently it’s pretty hard because the ads are hosted on the same server as the content

I use this and only this one and it works extremely well. https://oisd.nl/how2use
As for YT the best you can get is uBlock Origin, everything else kinda sucks.

“Client has been rate-limited (current config allows up to 1000 queries in 60 seconds)”

Does anyone know what this error means, but more importantly, how to resolve it?

i keep getting this error
[✗] DNS resolution is currently unavailable
[✗] DNS resolution is not available

whenever i try to update gravity on pihole webinterface after adding the oisd for ads

1 Like

Any fix for the DNS resolution errors?

My fix for this is editing /etc/resolv.conf to

search home

Then restart Umbrel-startup. Resolv.conf edit needs added to docker-compose.yml for permanent solution but that’s beyond my ability so I just reapply my fix if I have to reboot.

1 Like

run this command then reboot device

docker-compose exec pihole sh -c ‘echo “nameserver” | sudo tee /etc/resolv.conf > /dev/null’

1 Like

Umbrel Team, this is still broken in 15.14.2. Can you please fix this simple issue.

Still broken in 5.16.2