Pi-Hole Default DNS

After setting up and logging into my pi-hole the default DNS is and I’m unable to change it or point my router to it. Does anyone know how to set this up so it works?

look for your IP address of your pi. (192.168.xxx.xxx)

make this your DNS server on your router/computer/device etc.

That didn’t work either

I setup pihole on a rpi-zero a few months back and followed these instructions: https://linustechtips.com/topic/1094810-pi-hole-setup-tutorial/

I believe you could jump to “Stage 3” since you are using it on umbrel.

I’m able to set the DNS on my devices but I’m unable to find out what the DNS IP is, I have tried the device IP of the umbrel and that doesn’t work. I also tried using the DNS default in pi-hole “” and I’m unable to save that into the router. I just need to find out what IP I’m supposed to connect to.

it does work, you must not be doing it correctly.

all you do is set your WAN/LAN DNS on your router to the IP of your umbrel/raspberry pi.


I have the same issue, simply setting the DNS to the IP of the PI does not work. I’ve had a Pi-Hole before so I know how it works, but there seems to be some sort of issue now that its running alongside Umbrel and other apps. Looking at the system settings Pi-hole seem to have no IP either image

Thank you so much! Worked for me.
Set the Primary DNS on my router to the IP address of my Umbrel. Worked instantly.

1 Like

You’re welcome :sunglasses: isn’t your umbrel IP address, it should be a 192.168.xxx.xxx type IP address that you can use to access your umbrel (umbrel.local or the IP will work in loading up your umbrel dashboard)

once you have the correct IP address of your umbrel, simply use this as your primary dns server on your router.

did you go to Pi-Hole 's Settings - DNS - Upstream DNS and add umbrel’s address or just leave it to default?

nope, all default.

I did change the default dns supplier to quad9 though instead of google.

1 Like

mine doesnt not seem to work correctly… :[, never mind, will study more like a 6 grader lol

I’m aware, it’s currently, and I can access Umbrel and the Pi-hole web-gui perfectly fine with that IP, but using it as a DNS simply does not work.

My Pi-Hole node & Network / Umbrel Config

I have figured out my new network mapping and hostname naming scheme and sorting out my home/office/Lab network, now its just a case of propagating these changes over my machines/devices.

Coupled with strict HIPS rules on the LAN side and also Firewall rules on the router WAN side in/out traffic. Basically hardening the node/network without breaking anything inside Umbrel beyond repair :wink:

Pi-hole is managing my networks DNS but needs amending.

  • Pi-hole acting as DHCP server is my next move
  • Checking if its possible to run Pi-hole in userspace as opposed to pi-hole running as root
  • Pi-hole routing of Tor .onion addresses and see where I stand with this side of things…

As per the git issue comment in the following location:

cat ~/umbrel/apps/pi-hole/docker-compose.yml

# Pi-hole doesn't currently support running as non-root
# https://github.com/pi-hole/docker-pi-hole/issues/685
# user: "1000:1000"

I’m unsure if changing the default moneyprintergobrrr password which is hardcoded in the docker-compose.yml file will be persistent over any unintended / forced restarts my umbrel node may face and/or if its better to:

sudo pihole -a -p MyNewHard2GuessP45SWord

Something like that…

  • But may require further reading on how Umbrel manages authentication JWToken if this is why its not mapped to platform wide authenticated user acct.

After some more research online, I found out my Bell Modem allows me to change my DNS server, but it doesn’t actually get applied to the Modem settings. So that’s why I couldn’t connect the modem to the pi-hole. I tried hard programming it into my phone with the IP address of my node, and it works perfectly. Thank you all for the help.

You might need to change a setting. Go to settings - click DNS tab and tick 'Listen on all interfaces - permit all origins. Just read the caveats and make sure your pi-hole server is not directly connected to internet but behind a router/FW.

Same for me, I tried this too. Also what @17410742 is pointing out. When I use the IP of the Umbrel as the DNS in my router I cant connet to websites… There is one step missing I think.

Does someone know how to get Unbound running on the Pihole-umbrel? Then I can use the upstream DNS, if i read it correctly. https://docs.pi-hole.net/guides/dns/unbound/


I changed it to; Quad9 (filtered, DNSSEC) and it looks like its doing something but didn’t change my DNS setting in my router. thats just ‘dynamically from ISP’.