Node having hard time to connect and not syncing


I’m having a hard time with my node.

I rebooted it yesterday after seeing that my node lost its IPv4 connectivity.

Since then, the node has been having a hard time to connect to peers.
I ended up adding manually nodes through the following command:

./scripts/app compose bitcoin exec bitcoind bitcoin-cli addnode

After adding many nodes i manage to have around 15-18 peers ( clearnet & tor ). However the node does not download the missing blocks and therefore does not sync.

The bitcoind logs show some recurring elements that tickles me but i might not understand fully.
The first one is this :

2023-02-09T14:19:52Z Potential stale tip detected, will try using extra outbound peer (last tip update: 3778 seconds ago)

The second one is this :

2023-02-09T13:58:36Z Timeout downloading headers from peer=61, disconnecting

I don’t get why this happens nor what i can do to resync the node. I must admit i’m a bit stressed out as i have 7 channels opened on LN that i can not manage nor monitor until the node get resynced.

Any help would be really appreciated <3

P.S : I ran the following command, no inconsistency found :

./scripts/app compose bitcoin exec bitcoind bitcoin-cli verifychain 4 100

A bit of information regarding my node :
Umbrel Version: 0.5.3-build-d6641f8
Bitcoin & LND app versions are up-to-date.

Feel free to mention if there is any information missing here that could be useful

Can you verify that node is getting out to the internet?

If you can ssh in just use


If that works make sure your dns is working with


You can also SSH and run this command to get your logs

sudo ~/umbrel/scripts/debug

There is instructions for how to ssh in the faq


Hi @ParkerS, sorry for answering that late.

Yes, the node had access to the internet. Everything looked to run fine.

I ended reindexing the chainstate, which seems to have fixed the problem. It took a few days due to latency of the connection but after reindexing the local bitcoind managed to catch up with remote peers.
I still have no explanation on what happened.

I uninstalled many applications to see if any could be source of the problem, nothing was changing.

Digging on the web i found this: . However i found it after starting the reindex and didn’t think on trying to uninstall mempool first, so i can’t ensure this could be linked.

hey @ParkerS,

I was having a similar issue, since October 2023, and I reflashed my SD (on the current and a new one) and am able to get into the Umbrel home, but now I cannot connect to any app - Bitcoin never updates/loads/refreshes, stuck in “Starting”, and Mempool says OFFLINE with flashes of RECONNECTING… so seems like it’s not online.

I followed the SSH instructions and logged into my node that way, and tried pinging - didn’t seem to work… just kept pinging for a long time (vs. when I do it from my local computer, it worked after 4 pings no problem).

How do I troubleshoot getting my node back on the internet? It’s clearly connected to my router because I can SSH in through my wifi.

Troubleshooting log is attached (from after my Umbrel OS update to 0.5.4

Thanks in advance!
umbrel-1707006652517-debug-after0.5.4update.log (56.6 KB)