Network issues after updating to 0.4.11. Tor leaks?

After updating to 0.4.11 I’m seeing numerous connectivity related issues. I can no longer connect to my BlueWallet wallet connection nor the Sphinx relay server.

Looking at my firewall logs I now see a ton of connection attempts outside tor. These are all blocked by my gateway firewall since Umbrel is supposed to route everything through tor. Whats going on?

Only you can answer that.

We can’t control your firewall.

No, but Umbrel by default tunnels everything through Tor. Meaning as long as you allow Tor traffic (which can tunnel through port 443) you don’t need to allow any additional traffic. However, following the update to v0.4.11 that doesnt seem to be the case, causing all sort of breakage for those of us who enforce the tor tunneling on the network layer.

When i look the peers of BTC, I see much more IP address than Tor addresses (9 IPs, 3 Tor). Is that normal?
SSH and do command
/home/umbrel/umbrel/bin/bitcoin-cli getpeerinfo
to look peers.

That’s normal, the traffic is still tunneled through tor.

Since the new update, I get no connection to my node with Zap or Zeus.
I get messages like:

unable to connect to LND
Host (XYZ.onion) cannot be resolved. Please update your wallet connection settings…

Yeah, I’m seeing a similar issue with BlueWallet

Same here since I updated v0.4.11

docker-compose logs --tail=20 tor
ERROR: No such service: tor

Also tried to see if tor is working
netstat -ano | grep LISTEN | grep 9050
tcp 0 0* LISTEN off (0.00/0/0)

Last I tried to check tor service status
sudo service tor status
Unit tor.service could not be found.

However there seems to be tor peers connected with the command
/home/umbrel/umbrel/bin/bitcoin-cli getpeerinfo

Same here, plus that the web interface got stuck like this:

Try, making a new connection in Zeus.
At each restart, Umbrel is refreshing the TLS certificates, so who knows maybe yours expired or something.
Scan again the Zeus QR lndconnect code to connect.
BTW, Zeus just launched a new version with improved Tor and new design
iOS TestFlight
Android APK

My Umbrel with Zeus and BW works perfectly. Tor is slow and buggy, but works.

Just did a restart of Umbrel while monitoring my firewall logs and I see a ton of traffic that should be routed through Tor which isnt. This breaks effectively breaks a lot , if not all Umbrel apps IF you have a firewall that blocks outbound connections not going through Tor.

Actually, after further investigation, the connections I’m seeing are in fact to known Tor nodes. But it seems after upgrading to v0.4.11 that Tor is no longer tunnelled over port 443, but now uses a plethora of different ports.

Yep, I notice the same that in 0.4.11 tor service it doesn’t exist.
Maybe was renamed or is running in another docker instance, I couldn’t find it.
But my node is accessible just fine through onion address, Zeus, BW, Electrum, Sparrow works just fine with my node.

Hey, chiming in here - just checked with the devs and there was a change to the tor container in 4.11 to add in more relays, but the connection issue should resolve itself within a few hours with Tor coming back online. Anyone else on this thread having issues after awhile, let me know.

There’s no issues with Tor not working. My node is just fine with Tor connections.
It just that is not responding to logs command anymore.
If you run (like many times before) the command
docker-compose logs tor
the result is
ERROR: No such service: tor

So is strange. That’s why I think it was moved/renamed or something.

1 Like

Same issue … try with zeus nothing … any suggestion ?

Indeed, this commit is the most likely culprit. After some investigation it still seems like all traffic from my Umbrel instance is routed through Tor but it’s now using a gazillion different ports which makes it nearly impossible to create a sensible firewall ruleset for outbound traffic.