Can't access Umbrel over Tor after the 0.4.0 update


Umbrel access via Tor used to work well. I have updated to the 0.4.0 Umbrel and now I can’t access Umbrel at all. I get the following message

Onionsite has disconnected

Details: 0xF2 — Introduction failed, which means that the descriptor was found but the service is no longer connected to the introduction point. It is likely that the service has changed its descriptor or that it is not running.

Any help would be appreciated

Thank you


i have the same problem and get the same error message

1 Like

Seems I got a new onion URL when I upgraded. Can be found under Settings.

Same problem here. Anyone found a solution?

1 Like

I also have this issue - checked and the onion address listed in settings at umbrel.local is the same.

I don’t see the error message but everything since the upgrade has been like molasses and I just keep having to reboot the node. So far I’ve never seen my lightning channels since the upgrade and I’ve been trying for over a day.

1 Like

Same here :confused:

1 Like

Thanks for the heads-up, all. I was just about to push the upgrade button. I’ll hold off and wait until someone from Umbrel chimes in about this.

You just need to let your umbrel running, TOR will retry again and again until it works, TOR network seems to be overloaded, this is not related to umbrel and the latest update. I tried to roll back to previous versions, I had the same issue, it fixes by itself randomly after some time, it can also stop for some time, TOR devs are probably working to fixes this.


True. Thx After 5 hours its working

Would that account for the fact that I have almost no peers? It’s been overnight and I’ve got a grand total of 2 on-chain peers so far.

Edit: My ship finally came in… Took it long enough but all my peers showed up and lightning channels are back online after a mere 2 days.

I also can’t get on Tor – though a bit of a different error. I just get the standard “This site can’t be reached”. It happened sometime after I upgraded but not immediately, I noticed it after I installed the NextCloud app, it worked long enough for met to get the Tor address for nextcloud at least. Then awhile later it broke. I figured it would just fix itself as all the other domains (mempool, NextCloud, pi-hole) were still accessible on Tor. But it’s been overnight and this still hasn’t fixed itself. Accessing locally on umbrel.local says ‘running’ happily.

Specs: Umbrel 0.4.0 updated, running on RPi Model B 4 GB

Tor seems to be up and running fine on the Pi itself – as this command returns the “Tor confirmation” page

curl --socks5-hostname

The real pain is now I can’t keep working on my NextCloud – I lost the URL and the only way to get it is by logging into Umbrel through Tor and then going to the app.

1 Like

aaaaaaand Umbrel dashboard over Tor is back to working. I bet it was the Tor issue everyone was talking about.

That said, I did a hard restart (shutdown, power off and on) recently. Doubt that was the solution though.

1 Like

Tor Browser does not see Umbrel .

Umbrel still not opening- just spinning. :dizzy_face:‍:dizzy:

anyone get a solution to this?

I get this when I launch Tor and look for umbrel local

Unable to connect

Firefox can’t establish a connection to the server at umbrel.local.

The site could be temporarily unavailable or too busy. Try again in a few moments.
If you are unable to load any pages, check your computer’s network connection.
If your computer or network is protected by a firewall or proxy, make sure that Tor Browser is permitted to access the Web.


@litpixel You use your regular browser for umbrel.local and the long onion address on the Tor browser – you’ll find the long onion address if you connect to the HDMI port on the RPi OR look at the dashboard under Settings > Tor.
@BTC_Lumpen-Prole – please see above.

1 Like

thank you. thats very helpful

1 Like

@litpixel: You’re very welcome, my friend. :smiley: