Lnd stopped working

My lnd stopped working after configuration change.

I tried to setup it as public node with external ip.

I have internal server error now.

Error: Request failed with status code 500

What may be wrong here?

Why are you showing an useless “view source” of the web dashboard?
Is totally useless that and is not representing what the node is doing.
Please generate the debug logs and see what is wrong.
You said first that you changed something in lnd.conf - so change it back how it was and next time you edit it, be careful what you put and where you put.

I recommend you to read:

I can’t load debug log.

I also can’t even restart it.

And also the biggest problem is I can’t login through ssh.
Ping is working, web interface is working (static part).
Bitcoin node is working (syncing)
Lnd is not working.

What can I do now to avoid channels backup and syncing it all again?

That is the last resort. Your node is just not starting, nothing is wrong with your channels.
If you cannot enter SSH is because your node changed its IP or something.
If you can connect that monitor and keyboard, just go back and edit lnd.conf with default settings, then run the commands to restart the node (see troubleshooting manual).
You can also rename or remove that lnd.conf file and restart the node. It will generate a default one at startup. Later you can edit it, but only after you see your node starting correctly and be caareful next time what you edit.

cd umbrel
docker compose logs bitcoin
docker compose logs lnd
docker compose logs electrs
docker compose logs tor_server

To restart from command line:
sudo systemctl start umbrel-startup

I cannot login through SSH.

gkucmierz@MacBook-Pro-Macbook ~ % ssh umbrel@
ssh: connect to host port 22: Operation timed out

Ping is working fine:

64 bytes from icmp_seq=8364 ttl=64 time=2.847 ms
64 bytes from icmp_seq=8365 ttl=64 time=2.764 ms
64 bytes from icmp_seq=8366 ttl=64 time=2.496 ms
64 bytes from icmp_seq=8367 ttl=64 time=1.773 ms
64 bytes from icmp_seq=8368 ttl=64 time=1.723 ms

mDNS service is not working too so I am using local ip.

How in the name of satoshi a dns will work with a .local name?
Did you read my guide about how to setup a static IP for your node? It is explaining clearly how to set that .local name in your hosts file in your PC from where you accessing.
If not, just use the damn IP, is nothing wrong using the IP.

So enter SSH through that IP and remove that damn lnd.conf. That’s it.
You over complicated things where is so simple.

@DarthCoin you didn’t understand me.

I used before ssh umbrel@umbrel.local or ssh umbrel@umbrel-2.local for second node.

But now I am using local ip because mDNS service which is running on umbrel is not working.

The biggest problem is that ssh is not working so I can’t even login there to set up anything.

Is there any chance to fix this node or should I restart it and start all over again (two long weeks for syncing)?

No. I think you have a simple problem of not being able to access the right machine. No need to restart all over just for that.

Running 2 nodes on same LAN without static IPs is quite crazy, no matter what DNS you run.
As I said:

  • set a static IP for each node (if you have 2)
  • if you want to access through umbrel.local name, add in your local PC hosts file the lines for each node
    192.168.x.x node1.local
    192.168.x.x node2.local
    Or just don’t use names, use IPs to access them, is absolutely the same.
    Each one will have a different Tor onion address anyway.

Forget about any dns app you use, the static IP is what matters. And if you do not configure it into each node machine, is useless anything you do, because you will never access the right one.
Always SSH using each IP for each node.

I removed all data on ssd already.

But I still can’t connect through ssh.

Can os on sd card be broken?

I am using static ip.

Can I change bitcoin.conf now to make fast sync (disable most checks)?

Can I run Umbrel from usb stick instead sd card? (I don’t have sd card reader now)

So you decided not to read the troubleshooting manual but you want to fix your mistakes by magic…

Why? I told you is not necessary

Why not sd card could be broken? Reflash it with latest umbrel version. OS always is on mSD card and user data on SSD.

How? by setting up in your router? That is not static IP. You have to set it in the UmbrelOS config so that will be the IP communicated to the router, not the way around.

No. But what you can do is to point to another node already synced that is in your LAN (see the troubleshooting manual, is explained there)

NO. Usb is really bad for OS. If mSD is bad, USB is really bad.
How that you don’t have anymore a sd card reader anymore? Is broken the RPi or what?

Man what a mess you have there…

Ok thanks. I will read manual again and start everything again, thanks.

After resetting everything (sd card and ssd drive) everything looks fine (lnd is connected and active and bitcoin is syncing), but I cant still connect through ssh.

Can this be because I attached mac address to specified ip on my router? (DHCP setting)

I was using this before and everything was working.

I am trying to perform my channels recovery now (How to restore your node wallet)

But I cannot do this because scp is using ssh which is not working in my case.

gkucmierz@MacBook-Pro-Macbook ~ % scp Downloads/channel.backup umbrel@ 
ssh: connect to host port 22: Operation timed out
lost connection

Can I get some help here please?

Use static IP on the device, not on the router. As I mentioned in the guide.

You better start a new fresh new instance of node.
Recover the funds from dead node into Blixt node app.
Or you could try another approach: take out the SSD, connect it to another PC, copy the backup file somewhere in the umbrel/lnd folder and then put it back into your node, and run the restore using that path where you put locally the backup file.