LND `lncli unlock` command 'succeeds' but wallet isn't unlocked

umbrel-1634484152324-debug.log (35.6 KB)

Update 09:30UTC 18 Oct

Having had another look at the Umbrel logs, I can see that Bitcoin Core is telling me ThreadRPCServer incorrect password attempt from

So, it looks like the problem is that the password being passed from LND to Bitcoin Core is incorrect…but I haven’t changed it. Confusion continues… help appreciated, I am getting worried about my funds now. If the answer is ‘refresh and you’ll be fine’ them I’m happy to do that, but only if I can be confident I won’t lose access to any of my lightning funds!

Initial Post


I am able to unlock my LND wallet through SSHing into my Umbrel and then using lncli unlock. However, immediately after the terminal tells me lnd successfully unlocked!, the lnd bash prompt crashes. On restarting it, any lncli command responds by telling me that the wallet is still locked.

I am unable to access my bitcoin (mainnet) wallet or lightning wallet


  • I changed lnd.config with the addition of a node alias. However, in doing so, I accidentally inserted a random character, meaning on starting Umbrel the bitcoin node synchronised, but nothing else did, including Thunderhub so…
  • Not understanding what had happened I carried out the instructions at Umbrel Troubleshooting Guide under ‘One Umbrel app doesn’t start’.
  • This still didn’t fix the problem so I investigated the Umbrel troubleshooting logs and discovered the line about lnd.confg being malformed. I fixed this (I think!) and restarted the app.
  • This time I still couldn’t access my wallets so again investigated the logs. This time the key information was:

INF] LTND: Waiting for wallet encryption password. Use lncli create to create a wallet, lncli unlock to unlock an existing wallet, or lncli changepassword to change the password of an existing wallet and unlock it.

  • Thus began some reading and research to work out how to do this but I am now stuck as the SSH/LND bash commands don’t seem to be working.

SSH text

bash-5.1$ lncli getinfo

[lncli] rpc error: code = Unknown desc = wallet locked, unlock it to enable full RPC access

bash-5.1$ lncli channelbalance

[lncli] rpc error: code = Unknown desc = wallet locked, unlock it to enable full RPC access

bash-5.1$ lncliumbrel@umbrel:~/umbrel $ docker-compose exec lnd /bin/bash

bash-5.1$ lncli unlock

Input wallet password:

lnd successfully unlocked!

bash-5.1$ umbrel@umbrel:**~**docker-compose exec lnd /bin/bash

bash-5.1$ lncli getinfo

[lncli] rpc error: code = Unknown desc = wallet locked, unlock it to enable full RPC access

Umbrel Debug Logs Attached

1 Like

Issue Resolved

I ran rm ~/umbrel/lnd/lnd.conf && ~/umbrel/scripts/configure && sudo reboot

TY for those who helped!


the main issue is this which happens after wallet open. Did you change the default wallet password? Do not set your wallet password same as your dashboard password or else umbrel will reset it to default (moneyprintergobrrr) and then you can have confusion.

Also it would help you can post your lnd.conf as well.

lnd | 2021-10-17 15:16:43.599 [ERR] LTND: unable to create chain control: status code: 401, response: "" lnd | 2021-10-17 15:16:43.632 [INF] LTND: Shutdown complete

How do you set a different password for your wallet. I don’t remember having that option

I’m still having the same issue of my lnd wallet being locked.

  • I tried “lncli unlock”. It says “lnd successfully unlocked!”, but I still get the error message when restarting Umbrel.

  • I tried “I ran rm ~/umbrel/lnd/lnd.conf && ~/umbrel/scripts/configure && sudo reboot” but I still get the error message.

  • I tried rolling back to 0.4.1, but I still get the error message.

I’m running out of ideas here. Any help much appreciated, I can’t be the only one with this issue. Log file attached, thanks.

umbrel-1634741929470-debug.log (26.7 KB)

I note that the Bitcoin bit of your logs has the line:
bitcoin | - Unable to parse settings file /data/.bitcoin/settings.json

Have you amended that file? Might be worth checking it to see if it is malformed for any reason.

1 Like

Excellent work! Turns out my settings.json file was empty. I replaced it with “{}” and now I am back up and running. Thanks hmsgooch, your keen eyes are much appreciated!

1 Like

No worries at all!

Running the “~/umbrel/lnd/lnd.conf && ~/umbrel/scripts/configure && sudo reboot” worked for me.

1 Like