LND address over http://bridgeaddr.fiatjaf.com/ stoped working

Not a long time ago I was able to set my own LN address referring to: How to setup LnURLPay or Lightning Address the easiest way - #7 by Frog

I have been doing some setting changes for both the lightning node and the bitcoin node opening it to clearnet connections and sending it to my address stopped working.
Initially, I suspect this might be incorrect DNS records for my domain, but now I don’t believe this is the case and don’t know what else to check.
I have triple-checked DNS settings and also baked new macaroons.
I have made the setup for another domain with the same results.
I have loaded the default setup to both Lightning and Bitcoin nodes (closed clearnet inbound).
No matter what I always get the Lnurlp error. Any ideas what else to check are welcome.

Waiting support, sorry for the perhaps basic question, but have you tried checking if your node is listening on port 9050 or if there’s a firewall drop? :blush:

That should be Tor connection. so opening ports for Umbrel should not be a problem I believe.

you can check it!
From CLI by root
apt install net-tools -y
netstat -lntp|grep 9050
if present the TCP port is listening

Thanks a lot for the suggestion, yes LN proxy is listening at the port.

[sudo] password for umbrel:
root@umbrel:/home/umbrel# netstat -lntp|grep 9050
tcp 0 0* LISTEN 1502/docker-proxy

I have even set the port forward on the router to the internal IP of Umbrel to test the theory. Still the same error…

The thing is the connection from the bridgeaddr to Umbrel is Tor. I have limited knowledge about Tor, but I think, the onion address should point the traffic to the right machine directly (Umbrel) and REST will come from one of the Tor exit nodes. If the connection is refused by Umbrel LN proxy, there has to be another reason for that.
I will dig further…

Checked firewall and added accept rules for bridgeaddr IP. This didn’t help either.

I didn’t find any solution and don’t know how to debug further… It’s sad as it was working before.
In the end, I have configured the BTCpay server on my Umbrel node so now I have the lightning address working and the Pay button as a bonus.
It took me less time (2 hours) to follow this excellent guide:

I hit this issue while trying to setup a lightning address. I thought it was my node but it turned out to be the bridgeaddr service that was throwing the error. I used the same DNS params with https://satspay.to/ and it worked first time. Not quite identical, unless you run your own service, but useful to test your node.

Thanks, I have tried this and it didn’t work either. Anyway, I am happy with the BTCpay server solution. Kudos to Jorijn Schrijvershof for Installing the NGINX reverse proxy with an SSL certificate for Umbrel / BTCPay Server which is working with Umbrel 5.0.4 with just one more step at the end: How to configure Umbrel BTCPay Server with NGINX reverse proxy - #84 by bradlives