Lightning channel stuck in "Waiting Close"

Managed to get my remote peer to close on me. Funds did not show up in Umbrel.
Proceeded with the chantools sweepremoteclosed command. It managed to find the missing UTXO, I set the command to sweep to my Umbrel node and it appeared succesfull but the funds never showed up. When checking on-chain it swept to a different address than the one I specified :triumph:
I even did the genimportscript which resulted in only less of my funds being found when imported into electrum wallet. Seems like this whole thing is screwed, everything is working against me and no-one is apparently bothering to reply or help on this forum so I’m left fucking about and screwing up things further. Now attempting to rescan wallet transactions. Praying it still shows up, if not funds are lost. Taking all my funds out of umbrel before I lose even more.

1 Like

After running the command as outlined in the guide, nothing appears to happen. Just the command prompt comes up again. The channel I want to force closed is still in the “waiting_close_channels” list.

~/umbrel/scripts/app compose lightning exec lnd lncli closechannel --force …

diikco is right. he made his point.
you are very unpleasant to deal with.
you accuse everyone of wrongdoings instead of explaining it to people.
you deal with humans, not with machines.
learn some basic human behavior and have some respect for other people.
if you do not like what you are doing, do something else

umbrel gave me the same problem
please update about a solution

might want to try this. had same issue and this fixed it.

http://community.umbrel.com/t/restored-wallet-two-channels-wont-close/4672/6?u=stargati

Anybody could help me? I dont know the reason why its pending for weeks…

Try this.

You will need to ssh into your node, not via the lightning shell app.

Hi Mikey,
what i did wrong or can i try something else … ?

I had channel open TX in limbo after weeks bc of too low fee in mempool…
I read that after 2 weeks without TX confirmation, this TX becomes inactive and has to be force closed.
So i did try force close it via: ~/umbrel/bin/lncli closechannel --force … //channel point “space” 0

My channel opening TX changed to channel closing TX - my LND app showing this on Umbrel but the TX ID is not found in mempool (mempool waiting for TX to appear…)
instead the original channel opening TX with low fee looks still valid in mempool waiting for confirmation

When i used ~/umbrel/bin/lncli pendingchannels i can see there closing TX but not force close TX …

So i think the TX was closed not force closed in LND but was not broadcasted into mempool …

Any idea?

Many thanks
G.

@Diiikco @zipfastlnd @mugiwara

Hi mates,

I have exacatly the same issue here. My node was offline, tried to recover but there is one channel which has a status of waiting close. I tried to force close it but there is no maturity height.
Local and remote balance are shown 0, but in fact I have 1 mil sats sitting there.

I really appreciate if you could share your experience if you could resolve this issue!

Cheers