Lightning Adress - Failed to create invoice: missing kind

I tried setting up my own lightning address via my Umbrel node.
If I enter the email address in the Lightning address, it will be recognized and I can enter the amount to send.
As soon as I tap send, the message “Error failed to create invoice: missing kind” appears.
I tested it with both Macaroon Base64 Encoded and Hex Encoded. Unfortunately, it didn’t change anything about the error
I tested sending via bluewallet and Wallet of Satoshi. Both bring the same error.
I set up the address according to the following instructions:

Can anyone help here? I would be very grateful for any help

Is not about Umbrel. Is about how you configure/linked your node to that bridge server.
You should contact fiatjaf on Telegram @fiatjaf and identify exactly where is the issue.

missing kind means you put some string wrong in your DNS configuration. Review it. On the page of Bridgeaddrr it is explained very well what to put.

fiatjaf was able to find the error.
I created a subdomain like e.g.
But I had all the settings on instead of
That didn’t work then. After the adjustment it works :slight_smile:

1 Like

Continuing the discussion from Lightning Adress - Failed to create invoice: missing kind:

Hi Mrjln325, I´m trying to do something similar.
Can you please elaborate how to set up using a subdomain?
I currently have it working sucessfully with my entire domain. In other words, an address such as sats**** works

Instead however I’d like to use a subdomain in order to use an address such as sats****

How do I do that?

My host records (with information redacted) are shown in the below image.
Thank you!