Kernel panic during installation on a Pi5 without SD card (boot on M2.NVMe)

Hello everyone.

Here are the test conditions:
Raspberry Pi 5 without SD card, it boots directly on a M2.NVMe

The M2.NVMe is prior installed in a USB3 adapter and connected to a Linux PC
Image used: umbrelos-pi5.img
Sha256sum : bd3713ba0281e4fa3f1bd9a4b4db69d892c3959483e6211047aabf0bc090b9d9
sudo dd if=umbrelos-pi5.img of=/dev/sdc bs=4M conv=fsync status=progress
Installing M2.NVMe on the rasberry Pi5
Power On

It restarts every 60 seconds in a loop with a kernel panic each time.

I hope this will help us build a system that works in all situations.

1 Like

Here’s the PI5 I used without SD card and with the M2.NVMe 2TB

I’m getting the same kernel panic (sfdisk: cannot open /dev/mmcblk0: No such file or directory), when I tried to install it on my Raspberry PI 4 with the Argon ONE m.2 case, and a Kingston SSD drive

So far, I’ve only been able to get it installed on just the SD card which works fine. I’m gonna try to copy the SD card image onto the SSD and see if that works, when the OS is loaded via SSH (I know it’s worked for me in the past, when I installed PI OS.) I mainly just take the bottom of the case off and, connect it to my laptop via a USB cable.

From then, I just use balena to burn the image onto the SSD and put it all back together. It’s worth a try. Not really sure why that error pops up for. It also gives me a 30 second warning before rebooting.

@Woolfe25 did you manage to get it running without an sd card?

My sd card slot is broken so i can only boot from usb as of now…

Opened an issue here on GitHub: Not possible to boot from usb on Raspberry Pi 5 · Issue #1773 · getumbrel/umbrel · GitHub

Umbrel team says they don’t support NVMe based drives at all right now on RPi 5, much less booting from them. I’ve got multiple threads going on this right now. They claim they’ll add NVMe support for data storage drives in 1.1 but I’m not holding my breath. The best and obvious support would be to fully support RPi 5 and its PCI port, and allow us to boot from that MUCH faster device. I tried buying a USB3 shell for my NVMe 2 TB drive and even that had issues. At this time the kernel has not been built with the proper drivers to support the RPi 5 fully, at least as far as I can tell. I wiped UmbrelOS, reinstalled Bookworm, set the NVMe drive as the boot drive, and just installed Bitcoin Core directly, and things work great, and fast. I’ll reconsider Umbrel after 1.1 comes out if it supports booting from NVMe drives as it makes no sense to buy the latest RPi hardware and then use it as if it was older hardware. Can’t help but wonder if this was done on purpose as Umbrel sells a “PC” that does use NVMe boot drives, and adding NVMe support to RPi5 would have undercut selling their hardware. Oh well…

1 Like

Oh damn, i wonder if I will ever be able to use my Raspberry Pi 5 with a broken SD card slot for umbrel :frowning_face:

You’re not being kind to Umbrel, but it’s a fact that RPi without an SD card is a revolution. With mass memory on the PCI port, the operating system boot at the speed of light compared with the SD card. If the main application makes heavy use of mass storage, it’s all the same.
But in the end, that’s not the most important thing:
I’ve been using RPi for a long time, and SD cards always end up dying, even the best ones. An SD card in the long term is the cancer of the RPi.

At the moment, I think Umbrel is stuck with “Rugpi Silitics” and M2.NVMe (Silitics has to support NVMe first, if I’m not mistaken).

You’re right, about not being kind, sort of.

I fully support the efforts of the Umbrel folks. They’re a great team doing hard work, and they deserve to be congratulated. But, at the same time, when they did the transition from 0.5 to 1.0 THEY made a BIG deal about supporting RPi 5 as an awesome feature. But, in fact, their support is partial only.

When RPi 5 came out one of the MAJOR enhancements from RPi 4 was the addition of the PCI connector and support for NVMe. It was a significant reason to move to RPi 5 from RPi 4. Umbrel did not (and still doesn’t) caveat their implementation for RPi 5 at all. If they’d disclosed that their support for RPi 5 did not include support for PCI connected devices then I’d have ZERO complaints. And their support for USB3 based SSDs is a crap shoot right now (hence all the different failing enclosures).

I specifically went out, when they said that 1.0 would support RPi 5 was released, and purchased a RPi 5 with PCI/NVMe hat, a 2 TB SSD, case, etc so that I could install and use their very nice looking UmbrelOS 1.0 on that specific hardware.

And it’s not just that I did that…it’s that when any development team that has been around for awhile, and should therefore know better, is vague and/or misleading, they lose community trust.

I actually want them to succeed! But when you’re trying to expand and build a “product”, which I understand is that they’re doing by releasing 1.0 and stating it’s a “complete redesign from the ground up”, and also introducing a platform “Application store”, then you have to be transparent as to what you’re actually delivering.

I’ll be delighted if Umbrel simply publishes a prerequisites list that shows what they actually support. Easy enough I’d think, and done by most other communities I’ve participated in. I do a lot of work on ESP32/NodeMCU/LORA/Arduino micros and almost every library/package that is pushed has a “here’s what we’ve tested on and here’s what we know doesn’t work” document.

Umbrel currently shows “Run umbrelOS on a Raspberry Pi 4 or Pi 5 in just a few clicks. No technical skills required.”, and “Install anywhere else, Arriving in April 2024.” on their public page.

Do you believe “Install anywhere else, Arriving in April 2024.”? Do you have any idea when 1.1 will be out or if it will support NVMe boot, or just NVMe as a secondary drive?

Sorry to be less than “kind” but it would take 10 minutes to actually document what they support right now, and be transparent about it.

The other thing that is disappointing is that with all the discussions about this particular topic, they won’t post a reply that lays out the issues and what their plan is. There are numerisou other postings on this site that get replies within minutes of being posted, so they are obviously watching (hello guys) what’s happening here, but they are specifically not responding. Why?

You’ve developed your previous comments well, now I understand better. It’s true that so far Umbrel support hasn’t communicated about this M2.NVMe problem. Me too, I was fooled by the fanfare of Raspberry Pi 5 support, and it’s disappointing. Now I’m testing other things.

Hey guys this is now officially supported, there’s a public beta if you want to try: Release umbrelOS 1.2 Beta 1 · getumbrel/umbrel · GitHub

3 Likes

Hey @lukechilds!

Already tested it. And it works great. Thanks a ton!

1 Like