[ISSUE] Install BW App in Umbrel hangs [Closed]

Hardware/OS used: Gigabyte NUC x64, Debian 10
Umbrel ver. 0.3.10 - recently updated, manually

Steps I did:
All good, with a small minor issue, that Aaron helped me and fix it, dockers didn’t started well so we fix it with ./scripts/configure and the node started.

I waited until the node catch up and all channels and balances were online and good.
Tried to install the new app Bluewallet in Umbrel and was always waiting in “installing”…
I tried with 3 different browsers, waited also few hours
I restarted the machine (stopped manually Umbrel, then restart the machine)
I was waiting until the node again catch up and see all channels and functionalities are back online.
Start to install again the BW app and is still in “installing” never ends.
I checked if I can connect Electrum client and works, I check if all other mobile wallets can connect, it works.

I went to generate the error log from “Settings” page but I notice that is just reading an old one, not creating a new one.

At this moment I don’t know what to try more. Any advice? Is there a way to install manually that BW app?

Here is the debug link: https://umbrel-paste.vercel.app/e9cea7e4-a7ed-4d75-91ad-84a5ff848250

Update: this morning tried to uninstall LNBits app (was just for testing anyway) just to see if the node respond to this. Is doing the same, just keep saying “uninstall”… Maybe is something that is not starting the process of installing/uninstalling ?

Update 2: now I see some channels “inactive” (all Umbrel) but a friend of mine that is in the same ring of nodes, can see them active. All these inactive channels come from Umbrel nodes. All the rest of my channels are active and functional. I made even a tx to test. Works.

Update 3: I checked the Tor logs and seems that Tor service in Umbrel is broken. I can provide logs.

sorry about the issue, @DarthCoin. it looks like the background process that’s responsible for installing/uninstalling apps isn’t running. since you’re running a non-raspberry pi install, can you try this:

  1. stop umbrel: sudo scripts/stop
  2. restart the machine you’re running umbrel on: sudo reboot (this is important as it will ensure all the umbrel background process are killed)
  3. start umbrel (sudo scripts/start)
  4. try installing the bluewallet app again

(to watch app install/uninstall logs, you can tail -f logs/karen.log in the umbrel installation dir)

let me know if it makes a difference

1 Like

Thanks for reply.
The node is restarting now and is catching up (for about 15m now).
I would wait a bit more until all shows up correctly and then start again that installation.

What about the other issue appearing: channels that are “inactive” and are exactly from other Umbrel nodes (friends of mine) that updated recently. Could be something related with Tor and gossip (can’t find them)? Because other nodes/channels I see them OK.

it could be tor related because your lnd logs show:

failing link: unable to complete dance with error: remote unresponsive

but hard to say without looking at your friends’ troubleshooting logs

YES! all good now.
Restarted twice. Full restart.
I wait for the node to be full synced and all channels ready.
Run that “karen” command.
Start from dashboard to install BW app.
Looking into karen, pulling the docker image and installing it, after 1-2 min all good and app started.
Go back to dashboard and open the BW app, was empty, but after 20 secs I refreshed the page and all channels appeared.
Now I see also all other peers/channels active, all good.
Seems that was something with Tor connection.
Issue closed.

1 Like