Hybrid mode is voided when updating LND to v0.17.2-beta

My node was set up for hybrid mode before updating LND to v0.17.2-beta. When I go to advanced settings > tor & clearnet in the lightning app, the Hybrid mode is toggled off. If try to toggle it on then I get this error message

The settings in lnd.conf are still set up for hybrid, and I also checked my dns server.

My peer ping times are suspiciously high, and I am very unsure if my clearnet channels are actually still on clearnet.

Shouldn’t the hybrid mode button be toggled on, if my node is running in hybrid mode?

Edit: I checked the parameters in ~/umbrel/app-data/lightning/data/lnd/umbrel-lnd.conf and they are:


So the upgrade did not transfer the existing lnd settings, already set up for hybrid, to the umbrel-lnd.conf :unamused:

After upgrading lnd restarts - and I have also restarted the entire Umbrel after upgrading. The tor.skip-proxy-for-clearnet-targets=true simply does not replicate to the umbrel-lnd.conf.

I decided to manually change the tor.skip-proxy-for-clearnet-targets to “true” in umbrel-lnd.conf. After an Umbrel reboot, the ping time for my clearnet peers is generally back to 2 digit numbers (like what they were before the update). These are now my settings in umbrel-lnd.conf:

(so the tor.skip-proxy-for-clearnet-targets parameter changed itself back to “false” during restart, but the hybrid mode seems to work? - at least until next Umbrel restart…)

These are still the settings in ~/umbrel/app-data/lightning/data/lnd/lnd.conf (I did not change them in connection with this upgrade)
Screenshot 2023-11-25 at 10.00.23

While this is how the GUI looks:

There is definitely a disconnect here, and I hope the Umbrel team can fix this, so other users will not run into the same issue.

Thank you @Orville
umbrel-lnd.conf should not be edited, only lnd.conf for values not available in the UI
umbrel-lnd.conf streamlines this and helps with the UI settings, anything not available in the UI you can add to lnd.conf or the UI settings will supersede it,
I try to explain this easily but usually overcomplicate from the explanation available in “locating the lnd.conf section in the FAQ:” Official Umbrel Troubleshooting Guide and FAQ

I believe this could be fixed by deleted umbrel-lnd.conf…
sudo rm -rf ~/umbrel/app-data/lightning/data/lnd/umbrel-lnd.conf

and restarting lightning (you can just do that from the UI scrolling down on advanced settings and save and restart), which should recreate umbrel-lnd.conf

Checking over everything else

Do you mind to share with me your whole lnd.conf?

We will ignore umbrel-lnd.conf

Trying to track any changes between already having hybrid mode and updating,
Hybrid mode is off by default will review and double check with eng team on this and reply with any further detail

We can then add anything not in the UI to the lnd.conf if necessary
(anything in the UI will supersede lnd.conf edits)

Change here may be related:

We’ve added accept-keysend conf option to advanced settings. It is off by default, but users can toggle it on to allow their nodes to accept keysend payments

This is the Received Keysend Payments option in Routing category under Advanced Settings, try also toggling this on/off and restarting to see if that error still there?

We can then likely cross reference everything, after sharing lnd.conf? And go from there

this disconnect to confirm here as well is tor.stremisolation is supposed to be off? So we must toggle that off and restart too… checking over networking things as well

I toggled off the received keysend payment and switched to hybrid. Error message did not appear and the node is now restarting. Yay!

I would like to be able to receive keysends though…

Will delete umbrel-lnd.conf later, if the first restart dos not work when I have the time.

I know that umbrel-lnd.conf is not supposed to be edited, but I chose to do so anyway because my peer ping times were very high, and tor latency has caused problems for my node in the past.

Thank you for looking into this! :smiley:

After restart: Settings are good (except for keysend now off) and ping times are good also. I will switch on the keysend later. Thanks again!

Great, glad to hear it!

Please let us know if you had any other issue,

Or any other questions we may address!