How to get Btc server to work with website

Hello. I’m been trying for awhile now. And I cannot figure out how to get the btc pay button to work on my website. Only works while behind my router. .local. Is this because of tor? I tried to conned using a tor browser and the button still didn’t work.
Do I port forward 80 and 443? I did tried that
I also tried dynamite dns but didn’t work. Anyone know what I may be doing wrong? I have a google website hosted on Wordpress.
Does the http setting when you make the store app make a difference? Seems not to change anything? Also does anything like a cname need to be made in dns
I praying someone can help me get this to work for my site. :pray:

Basic rule for all new Umbrel users:

  1. Go and read the guide from the Guide section of this forum
  2. In there also you have a guide how to do reverse proxy for BTCpay server. Here is also another guide that using the LNbits with reverse proxy, was able to adapt it for BTCpay server too.

All apps in Umbrel are behind Tor! Tor is NOT a clearnet network, so it cannot be visible by users that are navigating normally with regular browsers. They need to use Tor browser.
So your BTCPay server from Umbrel is behind Tor.
If your webshop is accessible through Tor, then you just have to use the settings of your BTCpay server containing the .onion address.

If you want your BTCpay server to be used also in clearnet (IP/domain) then follow the instructions indicated above and make visible your BTCpay into the clearnet world.
Yes, you will need to open ports and forward them to your node IP.


Hi. Thanks for getting back to me. I’m trying to get the port forwarding setup and 2 routers now have given me errors when I try to add the 2nd port forward. Says already in use. What do you think I’m doing wrong? Do I need a certain type of router?


So if it says port is already in use it actually means it… tech doesn’t lie so trust it :slight_smile: Is that port may be used by any kind of router admin panel? or maybe something else?

No. No ports are set. I set the 80 to 15080 and link it to the umbrel. Then when I get to making 443 to 15443 it says error port in use. Now I’ve looked up that this is common with port forwarding. With linksys net gear. Can anyone give me a brand they use that is working with port forwarding and with btc pay ?