How to change swap memory from 4GB to 8GB?

Even if I increase the swap memory, when I restart the node, it goes back to normal again. System settings don’t work either.


Hi to help troubleshoot can you provide a few more details on how you are swapping up to 8GB, are you upgrading the RAM on a Linux machine/Mini-PC, Desktop, Laptop, or something else? The main issue, is it the fact your Umbrel is not recognizing it is running 8GB RAM as displayed in the settings?

Oh I mean ‘swap memory’, swap space on Linux systems.

I’m guessing you have to setup the ubuntu-lv for more memory (if you’re running a VM), that was my solution…

so if I’m right you’ll have to rebuild the machine…


1 Like

Hello there,

I am having the same problem right now, I have upgraded my RAM to 8GB and Umbrel still shows 4GB.

I have increased my Swap File to 8GB and it seems like all my countainers are with a 8GB limit. I’m running on a PC with Ubuntu.