How install UMBREL on a linux-pc using an external HDD?

Hello dear community i wanto to use umbrel but i’m having some problems because i have an old pc with 4 GB ram but it have just 500GB HDD so i need to use something else and for this problem i have an external 1TB HDD that i can use, but i don’t understand how because when i install umbrel it will start automatically and i don’t understand how can i set to use the external HDD and not the pc HDD

1 Like

I would also like to use an External USB HDD to store the apps data files.

I intend to use a Bitcoin Core Node and Lightning Node.

How can we use an External Drive?

I would only recommend the usd of a SSD (external) HDD.
I started on Ubuntu using normal HDD and stopped after a week of synching (it would have taken more than a month).

With SSD it took about 5 days to sync.

I followed the guide on GitHub - getumbrel/umbrel: A beautiful home server OS for self-hosting with an app store. Buy a pre-built Umbrel Home with umbrelOS, or install on a Raspberry Pi 4, any Ubuntu/Debian system, or a VPS. which is now a one-liner.

Go to your externel drive:

cd external-drive
mkdir umbrel
cd umbrel
curl -L | bash

Don’t update umbrel the normal way on the web interface. I always got problems after that. Instead use:

sudo ~/umbrel/scripts/stop # or sudo systemctl stop umbrel-startup
sudo ~/umbrel/scripts/update/update --repo getumbrel/umbrel#$VERSION
sudo ~/umbrel/scripts/start # or sudo systemctl start umbrel-startup

where “$VERSION” is at the moment “v0.5.0”.


Thanks for this!

I think I will finally give Umbrel a try. I will use a separate laptop than the one currently running an already sync Bitcoin Core node.

Is there a way to avoid downloading the whole blockchain again i.e. copying from my already sync node?

I have my old umbrel folder mounted and I create a softlnk in the new umbrel/app-data/bitcoin/data folder to the old umbrel/app-data/bitcoin/data/bitcoin

so i did this but what seems to be happening is data is still downloading into the location ~/umbrel/

anyone else have this issue?

I ran the curl command from the external drive location. the goal was a fresh ubuntu install on a small nvme drive with umbrel install in an external drive that is default mounted at the location /data/ I ran the curl command from the external drive location /data/umbrel/ but it still downloaded all the data into the ~/umbrel location

it would be great if the respected the external location but it doesn’t seem to.

the solution was to stop umbrel perform a move to the original desired location and then start again