[GUIDE] Cloning or Migrating SSD/HDD (Windows)

Need help!
I am unable to connect to the node via ssh from windows 10.
Node is running fine.
I just cloned the ssd from 1 tb to 3 tb, and it worked as expected.
Now wanted to run ssh for growpart.
But keep getting permission denied when I try to connect (ssh) to the node.
It keeps saying Permission Denied (even when I am entering the correct password).
Please help!

Now I am getting the same error. When I run resize2fs, it says, nothing to resize. And the node stopped working! :frowning:

Please help/advise. Thanks!

Hi @DHD, The cloning worked perfectly as per your steps on windows 10 (thank you!).

However, the new bigger-sized SSD (3 tb) is still showing the old SSD size (1tb). Getting errors when I run…
sudo growpart /dev/sda1 1
WARN: unknown label
/dev/sda1: does not contain a recognized partition table

If I skip it and go to resize2fs, it says nothing to resize, and in the end, the node gets corrupted (becomes unusable).

Please help!

1 Like

I am having the same problem if anyone can help.

Use Acronis Image clone disk. It will resize automatically and make a data clone at cluster level (all file properties remain the same).
Is faster, safer and easier.

for me it worked leave out one 1:

sudo apt install cloud-init -y
sudo growpart /dev/sda 1 ( <---- only one 1 )
sudo resize2fs /dev/sda1
sudo reboot

idk why but I just tried this and it worked :smiley:

@sanjay @trader719 I think this could help you too :slight_smile:

2 Likes

@shroominic’s solution worked for me also!!! Thank you!

However, I am a psycho and I bought a 4TB SSD. growpart will only grow my previous to 2TB maximum. I found this explanation: https://unix.stackexchange.com/questions/429507/cannot-extend-partition-beyond-2tb-on-aws-ubuntu

however, the instructions are unclear on what I need to do specifically to unlock the full 4TB. Does anyone know how?

Are there instructions to clone in MacOS. Does using Time Machine suffice?

I need a guide of clone for MacOs too. Thanks!

I also need to clone using Mac. Does anyone have an answer on cloning a Mac?

Is this enought, just clone HD to SSD? There no need to reappoint the new device in the fstab?

2024 update:

You can actually still do the cloning with Macrium Reflect (which is still a free trial, while Acronis is nowadays a paid license for the cloning functionality) per the above instructions, however the cloud-init package (version 20.2) mentioned here has become outdated on Umbrel 0.5.4. and therefore it cannot resize a partition to more than 2 TB.

So if you have a 2TB+ SSD drive, the way around this is to mount your freshly cloned (larger, say 4TB) drive to a secondary Debian machine or Raspberry Pi, then run apt update and apt install cloud-init version 20.4.1 (or later) and then run the growpart and resize2fs commands.

You will notice that if you apt install cloud-init on that secondary machine, with your newly cloned drive mounted, the cloud-init package version (and the underlying growpart and resize2fs packages) are of a later version than the ones you would be able to pull with your Umbrel 0.5.4 node. Maybe, this will be resolved with Umbrel 1.0 but for now a secondary Debian machine or RPI is the way to resize your external SSD-partition to the fullest capacity of the drive.

I have done it with 4 TB but larger drives should also work. Keep in mind that your secondary RPI may have insufficient power to have two SSD’s mounted (its own + the newly cloned one which you want to resize) so it is best to run that secondary RPI using only its microsSDHC card. That way you won’t get a power outage when you reboot into your cloned/resized USB3.0 SSD-drive.

Hope this helps some more folks increase the size of their nodes in the lead-up to Umbrel 1.0!

1 Like

Hey there,

I am desperately trying to fix the issue with resizing the disk!
I cloned from 1TB to 2TB, followed all the commands, but when I try to resize (sudo resize2fs /dev/sda1) I get the following error:
resize2fs 1.47.0 (5-Feb-2023)
The filesystem is already 244190208 (4k) blocks long. Nothing to do!

The disk is still showing 1TB capacity.
I appreciate if anyone could support me on that!

Hey, maybe you are trying to resize a wrong drive or wrong partition.
What do you see if you run this

cat /proc/partitions

and this

df -h

in your SSH session?

Yes you were absolutely right. I shoud have used dev/sda instead of dev/sda1
Now it’s fixed :slight_smile:

Cheers mate!

1 Like