Replace 1TB SSD with 2TB SSD on pi

Is there a workaround for replacing the 1TB SSD to an 2TB SSD for my Umbrel installed on a Raspberry Pi?


I would like also to do this. Is there a procedure/instruction for this action?
clone the disk offline to a new 2 TB disk?

I have exactly the same issue at hand?

You are not alone. I will monitor this for a reply on how to safely clone my 1TB M.2 SATA storage drive to 2TB on a pi4

I tried to clone the SSD unsuccessfully. Carbon Copy Cloner didn’t see the old 1TB SSD on my Mac and using the DD utility command via Terminal was also no succes. It took too much time, after 18 hours it was at 45% and the Mac has to stay awake.
So after backing up the LND phrase I had to start all over again with syncing the blockchain on my new 2TB SSD.

I tried the dd command (sudo dd if=/dev/disk2 of=/dev/disk3 bs=1M status=progress conv=sparse) again and after 6 hours it cloned the 1TB SSD on the 2TB SSD.
When connected to the Umbrel, the node does not see 2TB but 1TB…very strange. All other apps are working as normal

Most likely the partition has to be extended/expanded to encompass all the space available on the new ssd.


Problem is solved.
I mounted the SSD on a Debian machine and resized is with the standard disk manager to 2TB because there was a small partition unused. After mounting it again on the Umbrel it works fine!

1 Like

Great to hear that this works.

Many of us will be running out of space these days.

Is there a step-by-step recommended process for “running out of disk space” for Umbrel on rPi?
I was thinking to backup the channels and the Bitcoin & Lightning accounts and “start fresh” with a new installation. Might be better to have a fresh operating system install from time to time anyhow.

What’s the best recommended practice for this situation?

1 Like