Error when trying to add watchtower on 0.5.1


I’m running 0.5.1 and am trying to add a watchtower. I was following the instructions (Umbrel Troubleshooting Guide under the section “how do I add a watchtower to my node?”)

I added the below to my lnd.conf file which on my machine is found here (umbrel/app-data/lightning/data/lnd/lnd.conf)



when I use this command:

docker exec -it lightning-terminal_web_1 lncli wtclient add

with the watchtower I’m trying to add at the end, I get this error:

[lncli] could not load global options: could not load TLS cert file: open /data/.lnd/tls.cert: no such file or directory

I went looking at the folder it was referencing this is where I found the tls.cert file


seems the program is looking for .lnd folder. Has anyone tried/successful adding a new watchtower on 0.5.1?

Thanks for any help.

I am having the same issue. Thanks for posting amafaskrowten.

I may have figured this out. I ended up looking at the /umbrel/bin lncli file and found the following deprecation notice. The command, for me, changed to the following - “./scripts/app compose lightning exec lnd lncli tower info”. Hope this helps

echo " *** Deprecation notice ***"
echo " In a future version of Umbrel, ‘lncli’ will be removed."
echo " Please instead use:"
echo " ./scripts/app compose lightning exec lnd lncli "

I was able to see that info also, unfortunately i’m a total noob with command line usage and wasn’t able to recreate the command to add the watchtower. I used different variations of commands and when I was in the umbrel/scripts folder and used command “compose lightning exec lnd lncli wtclient add” i got the error

Error: no “compose” mailcap rules found for type "cannot open `lightning’ (No such file or directory

I may have to wait until they make adding this as easy as mynode does with it as a setting.

Thanks for responding!

Agreed, could we get some clarification on the use? how would the cli go when trying to check on the watchtower or anything with the new standard?

Thanks in advance,

still no assistance.