Electrs stuck in failure loop

After LND wrecked my node about 3 weeks ago and Umbrel couldn’t show my balance, and I didn’t have any sats in LND at all, only in what I thought was my on-chain BTC wallet. I tried twice to start a fresh new instance with a freshly wiped SSD and flashed microSD. The second time after 3 days past full sync, Umbrel found my first transaction only. So, I decided to start another fresh instance but this time not try to recover my funds but use BlueWallet and transfer the funds to my new Umbrel wallet, this worked, minus the fees I had to pay. A few days later I logged into the node to find that it restarted syncing the blockchain from scratch again!

This time I decided to try another instance, re-format the SSD and fresh copy of UmbrelOS 0.4.8, it looked like it was syncing fine for a couple of days and last night it reached 100% sync. However, as soon as it reached 100% sync, electrs flipped out and began giving errors.

It’s stuck in a loop where it attempts to start, fails with the errors below, then tries again every minute. I tried looking up what the error means or how to fix electrs but I can’t find any material out there.

I have tried running
sudo systemctl stop umbrel-startup && sudo rm -rf ~/umbrel/electrs/!(electrs.toml) && sudo systemctl start umbrel-startup
but it returned to the same behavior and error messages.

electrs | 2021-11-20T20:15:26.966827974Z Starting electrs 0.9.1 on aarch64 linux with Config { network: Bitcoin, db_path: “/data/db/bitcoin”, daemon_dir: “/data/.bitcoin”, daemon_auth: CookieFile(“/data/.bitcoin/.cookie”), daemon_rpc_addr: V4(, daemon_p2p_addr: V4(, electrum_rpc_addr: V4(, monitoring_addr: V4(, wait_duration: 10s, jsonrpc_timeout: 15s, index_batch_size: 10, index_lookup_limit: Some(200), reindex_last_blocks: 0, auto_reindex: true, ignore_mempool: false, sync_once: false, disable_electrum_rpc: false, server_banner: “Umbrel v0.4.8”, args: }
electrs | 2021-11-20T20:15:26.967412325Z [2021-11-20T20:15:26.967Z INFO electrs::metrics::metrics_impl] serving Prometheus metrics on
electrs | 2021-11-20T20:15:27.011627758Z [2021-11-20T20:15:27.011Z INFO electrs::db] “/data/db/bitcoin”: 669 SST files, 0.000538545 GB, 0.000000021 Grows
electrs | 2021-11-20T20:15:27.033697086Z [2021-11-20T20:15:27.033Z INFO electrs::server] serving Electrum RPC on
electrs | 2021-11-20T20:15:27.098241092Z [2021-11-20T20:15:27.097Z INFO electrs::index] indexing 2000 blocks: [1…2000]
electrs | 2021-11-20T20:15:27.150318511Z [2021-11-20T20:15:27.150Z INFO electrs::db] closing DB at /data/db/bitcoin
electrs | 2021-11-20T20:15:27.153923800Z Error: electrs failed
electrs | 2021-11-20T20:15:27.154013615Z
electrs | 2021-11-20T20:15:27.154029393Z Caused by:
electrs | 2021-11-20T20:15:27.154041726Z 0: sync failed
electrs | 2021-11-20T20:15:27.154074004Z 1: failed to get block 00000000839a8e6886ab5951d76f411475428afc90947ee320161bbf18eb6048
electrs | 2021-11-20T20:15:27.154090152Z 2: receiving on an empty and disconnected channel

I can use some help please. I’ve also included my debug log below. Thank you.

debug.log.txt (31.4 KB)