Can't connect my BitBox App or Electrum Desk Wallet

I am successfully running Umbrel on my raspberry Pi4 in my local LAN, however, cannot connect either BitBox App or electrum wallet. Under BitBox App the following error is shown:
dial tcp connect: connection refused
Tried to change to LAN address of the Umbrel node but without success.
Any suggestions how to solve this?

Do you have Tor source code running on your computer?

Screenshot 2021-08-17 103302

TOR is not running on my iMac

It needs to be running. You need to follow all the steps in the connect wallet section for the Bitbox app to properly connect with umbrel.

Umbrel with TOR is running on my raspberry Pi. If I additionally install TOR on my Mac - what I did - I can only reach Umbrel via the remote access address and when following the instructions under wallet section for the Bitbox, the connection to Bitbox cannot be established.

You do not use the Tor browser but the Tor source code. You have to have that running on your computer when you are filling out the applicable sections on the bitbox app to establish connection.

ok, thxs. I tried to install the source code with homebrew but received the following notice:
Aug 19 11:20:52.227 [notice] Tor running on Darwin with Libevent 2.1.12-stable, OpenSSL 1.1.1k, Zlib 1.2.11, Liblzma N/A, Libzstd N/A and Unknown N/A as libc.
Aug 19 11:20:52.227 [notice] Tor can’t help you if you use it wrong! Learn how to be safe at
Aug 19 11:20:52.227 [notice] Configuration file “/usr/local/etc/tor/torrc” not present, using reasonable defaults.
Aug 19 11:20:52.229 [notice] Opening Socks listener on
Aug 19 11:20:52.229 [warn] Could not bind to Address already in use. Is Tor already running?
Aug 19 11:20:52.229 [warn] Failed to parse/validate config: Failed to bind one of the listener ports.
Aug 19 11:20:52.229 [err] Reading config failed–see warnings above.

Don’t know whether I did something wrong during the installation process - I am not an IT expert.
Can you please include your instruction link for installing source code from your first post; it was not working. Or any other suggestions?