Not able to connect Electrum desktop wallet to Umbrel over tor

Hello together,
since days I try to connect the Electrum desktop wallet (macos) via tor with the umbrel node (according the umbrel-tutorial in the section “Connect wallet”). Tor is running successfully as a background service and is listening on port localhost:9050.

Umbrel runs on a raspPi4 with SSD over wifi. The BTC-Chain is synced since around 2 weeks.

Would be great if any being here would have the patience to help me to bring up this node successfully… Thank you!


Tor is a bit silly lately.
There’s a patch 4.7.7 but you will need to update your UmbrelOS. Better wait for umbrel guys to update it, if you do not know how to do it.

Another trick is to use local IP of your node to connect to your electrum server.
But for that also you need to open the port 50001 in umbrel ufw.
And that’s it, you can connect on local IP:50001 with your electrum app. No more Tor.

Another trick is to use Tailscale, in special when you are out of your LAN. Works nice. Private VPN.

Thanks brother….do you have a tut for how to open this port 50001 at umbrel handy?

sudo ufw allow
sudo ufw allow 50001

Thanks again… I very much appreciate your patience!

But anyhow “ufw” command won’t work at my installation….any further ideas?

sudo apt-get install ufw -y

Ok sorry….this came from lacy mind.
I had to install it first “sudo apt install ufw”

So I changed the rules as you suggested and edited the “network —> server” entry in electrum with” and let the “proxy” checkboxes unchecked….

….but still electrum still doesn’t connect

hmmm, seems you have other problems there.
did you checked the logs of electrs?
cd umbrel
docker-compose logs electrs

See if is the index completed.

One important thing: must be in this format: 192.168.x.x:50001:t (or whatever local IP you have), but must contain that 50001:t

1 Like

Brother thank you very much! The “:t” made it finally.

That means in “Network”-window —> “Server” I put “” and
the “Proxy”-Checkboxes I left unchecked!

I super appreciate your support and will keep this as motivation to pass on knowledge when I get the opportunity… Thank you very much!


Hello DarthCoin,
this command is not working properly on my Umbrel (0.5.1)
umbrel@umbrel:~ $ sudo apt-get install ufw -y
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 9 not upgraded.
Need to get 164 kB of archives.
After this operation, 852 kB of additional disk space will be used.
Ign:1 buster/main arm64 ufw all 0.36-1
Err:1 buster/main arm64 ufw all 0.36-1
Temporary failure resolving ‘
E: Failed to fetch Temporary failure resolving ‘
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

The problem seems to be “failureresolving ‘’”
Otherwise my Node seems to run fine.
Btw. the output is the same when I use
sudo apt install ufw
sudo apt-get install ufw

Could you please advise me.
Thank you.

Update: I had a hunch that it might be caused by a faulty DNS entry in dhcp.conf.
It was set to
static domain_name_servers=192.168.x.1 (my router)
I set it to the first one of the DNS servers configured in my router.
Now I could install and enable ufw
But now all my channels are offline!
I run this set of commands:

sudo apt-get install ufw -y
sudo ufw default deny incoming
sudo ufw default allow outgoing
sudo ufw allow SSH
sudo ufw logging off
sudo ufw enable

This is the ufw status:

Status: active

To                         Action      From
--                         ------      ----
SSH                        ALLOW       Anywhere
SSH (v6)                   ALLOW       Anywhere (v6)

What is missing now? How can I get my channels back online?
Thanks a lot.

after a reboot all channels are back online.
Btw. the command

$ sudo systemctl enable ufw

was not successful

-bash: $: command not found

after reboot ufw status is nonetheless active.
Is there any guide availabe for using ufw with Umbrel 0.5.1?
Thank you very much.