Cannot update from 0.3.8 despite completing update process

Hi! So I’ve set up a new Umbrel node, however, when clicking on all of the options that allow to me update to 0.3.9 the install process starts and appear to go smoothly, yet when I’m brought back to my Umbrel dashboard I’m still stuck at 0.3.8

Is there any way to fix this? Am I just better off downloading 0.3.9 and reflashing?

Try a manual update as shown here


Thanks, but unfortunately this didn’t work. I did the manual update it appeared to be completed but didn’t reflect this afterward nor after rebooting. Trying another update through the dashboard didn’t work either.

I have the same issue on Linux, I manually updated it but still get the message new update available and the current version is 0.3.8 in the dashboard

I was having issues and posted logs but I figured it out so I deleted the posts. After rebooting and attempting re-install it worked fine.

Is there any specific way to get the log from the manual update attempt or should I just try running it again?

Here’s the pastebin for it

I got a “removing old containers message” on the dashboard and then got “~/umbrel $ client_loop: send disconnect: Connection reset by peer” on the SSH window.

This didn’t happen the first time I tried.

sorry for the late response but update v0.3.10 sort of fixed this problem, I mean I just didn’t get the issue this time