Cannot Install to an External dDrive

Hello, I am a pretty new umbrel user but have been doing tons of research lately on how I can make this thing better for the raspberry pi 5. Yesterday I went out and bought an 8TB drive and I installed raspbian to it, but soon learned that Linux will only use 2.2TB of the drive and the other 5.something TB is unallocated, since I spent tons of money on this drive I want to be able to use the whole drive. I then tried to install rasbian to my microsd card. I then configured my hdd to mount automatically with fstab and tried installing umbrel with the --install location /mnt/umbrel (location of my mounted hdd.) I am getting the error about permissions. anybody know a solution or have any suggestions on how I can incorporate my entire 8TB drive? Thanks!

Interesting, what was the issue you were encountering preventing you from using the full 8TB initially?

UmbrelOS uses the ext4 filesystem, and if you run UmbrelOS with Ubuntu/Debian, I would assume the relevant partition would expand to use the whole drive.
Can you please also share the install command you used before getting the permissions issue.

FYI we should also have an image for the Pi 5 that you can flash directly to your SD card and install UmbrelOS from shortly.

1 Like

Odd I run raspbian and use 2 - 4tb drives and they are fully allocated.