BTCPay Server app doesn't work

Hi, after installing the BTCPay Server the “BTCPay Server” icon appears under “Apps” section.

When I click on it I get a page that can not be loaded on http://umbrel.local:3003/

Chrome just writes: ERR_CONNECTION_REFUSED

Is this normal behaviour?

I have the same issue. Other Apps work and I am able to get to the Dashboard so the node is running.

Did you tried accessing the Umbrel/BTCpay using the onion address?

Error with onion address as well.

try reinstall update, manually

So I did re-install…same problem…can not connect. My node is up and other Apps are working. @tychsen - do you still have the same problem.

Try running the debug log and post here the link that it shows at the end of the process. Only the link not the whole log. The link contains the log :grinning:

I don’t see a link…I ran Log from Umbrel Settings. I could download the log file I can upload.

Yes I do. But my node is not fully synced yet. So that might be the problem (however it should not be).

I really struggle with what it could be.

I reinstalled…it works now.

1 Like

May The Coin Be With You…

Heyy… im still not making it work.

Reinstalled many times… run logging (says no problems)… can it really be the not yet finished sync of bc?

You have to have 100% Sync and then use Apps.

I will try that… however it could be UI improvement to block for installs of apps that require full synced BC until BC is 100%.

FYI you don’t have to fully sync.

I rebooted the device (for God know which time) and instantly started the BTCPay server app - this time it loaded. And actually notifies me about the not fully synced BC.

As I say it so many times… for a node operator, patience is the key.
People without patience will always pay a higher price…