BTC Core on HDD

I’ve just finished downloading Bitcoin Core onto a HDD and hooked it up to my Raspberry Pi running Umbrel. Umbrel now wants to download the blockchain all over again; how do I get Umbrel to recognise the BTC Core already on the hard drive?


It doesn’t quite work that way. Umbrel runs everything in its own docker containers. You could try transferring the database from your bitcoincore install to the data directory the umbrel’s btc container uses

1 Like

Yes @mrv777 is right in this case. You can use this guide here to transfer your existing data, but you’ll need to use an empty drive to get set-up with umbrelOS first.

1 Like

Been looking for help with a similar challenge, but related to NVMe. I came across this, but not sure if it’d work:

Is there a workaround with Umbrel v.1.1 that will enable me to use an NVMe board and install the OS and all data to a 2TB drive? Every time I’ve tried, the blockchain data goes to the microSD, I run out of room, and it stalls.

On an aside, it’s surprising that an OS that supports media server and file sharing functions (i.e. Plex) doesn’t support the storage devices to go along with it. That makes no sense to me at all. Seems that would have been a priority by way of basic function. Other than that, Umbrel is dead easy… if I could just get it to work with storage devices.

Hoping someone can help.