Bitcoin Node stuck "Starting"

I just tried this, but it doesn’t appear to have worked for me. My Node stopped syncing after it lost power without shutting down properly. I’ve tried a sudo reboot and your suggestion but no luck yet.

Good evening, I had to restart my node a couple of times and now the bitcoin node won’t start. I am a beginner and not sure if I have the same problem. As described above. The debug script did not find anything, so far I understood. A proper restart brings nothing. After login I always see the same as in the picture. Can someone help me further?

Best regards

1 Like

Hello, I do not understand, I can easily log in via browser but in the console my password is wrong? The node runs on a Pi4 and I use Manjaro as the main computer. Can someone help me please? LG

Hi! I am not an engineer, but my guess is you probably have to SSH into your raspberrypi ssh umbrel@ipadress of your raspberry pi.
if it asks for a password it will probably be money printergobrrr.

to you guys with the bitcoin node not starting due to a power outage. Do this.

And it cant hurt for you others as well.

ssh into your node

ssh <umbrel@your node ip here> without the ><

and then

sudo mv umbrel/app-data/bitcoin/data/bitcoin/peers.dat umbrel/app-data/bitcoin/data/bitcoin/peers.dat.bak

this makes a backup of your peers.dat file in essence deleting what your node is looking for. you could delete it if you want this is just my preference

to delete it if you want the command is

sudo rm umbrel/app-data/bitcoin/data/bitcoin/peers.dat

once you do either of those go to your bitcoin node if you can.

and restart it by clicking the three sot in the upper right. Choosing advanced and restart it.

If you cant get there go to umbrel and your settings and restart there.

This should get your bitcoin node back to running.

report back :slight_smile:

For visibility, I’m linking to my solution here.

Restarting didn’t work.
Adding {] to settins.json didn’t work aswell.
Deleting peers.dat didn’t work aswell.
I’m frustated, it was working fine for like 2 weeks and now all of the sudden this.

1 Like

do you have containers stuck in a startup loop?

ssh in
docker container ls -a

look for ones starting up over and over

Bitcoin Node app and every app related to it is in “Restarting” permanently.

if you can tell me what youve done what happened that may have caused the issue
were you synced? did power go out?
can you uninstall and reinstall?


My node had 11+ days uptime. Sudently one day it went down, no power out at my house, i just lost the connection to Umbrel… i restarted Umbrel and then everything was fine except Bitcoin Node (and all related apps like Mempool / Lightning /etc ). It’s been days and nothing has changed, i tried different methods but nothing has worked, i think i will just bite the bullet and reinstall Bitcoin Node and DL the blockchain from scratch.

First you’ll want to check the debug logs (see Generating Troubleshooting Logs here), if this is still occurring it’s usually one of three errors a corrupted blockchain error that looks like:

LevelDB read failure: Corruption: block checksum mismatch: /data/.bitcoin/chainstate/1066593.ldb

Solution is here under “Resolving Corrupted Blockchain Issues”

A peers.dat error can be resolved with these steps

Or a settings.json error can be resolved with these steps

Working to make the FAQ more accessible, any other recommendations or feedback welcome

And feel free to post your debug log via attaching it here or can attach it in the Telegram in the Support channel here


follow what usernameisJim suggests but you can probably save your chain.
I believe in those troubleshooting tips will be a way to recheck it.
hopefully you wont have to start over from scratch unless catastrophic disk failure


Thank you guys. But I already started over from scratch, if it happens again in the future i will try what @usernameisJim suggested. Thank you.

1 Like

I reinstalled Bitcoin node from scratch few days ago, and today, just a few hours later after reaching 100% blockchain download, my Umbrel crashes (for no reason) and the issue of “Starting” status returns… sigh

Hey @Syturio can you post a debug log?

You can reference Generating Troubleshooting logs in the FAQ and then attach it as a text file with this button here 6FEAF41B-0BD7-45C2-9B08-7CAB590306C9_4_5005_c or share it as a link from feel free to post here or in the Telegram for review

Thanks, it works for me

This thread saved my node. Thank you all.

So what you left inside the the setting.json ?


I was seeing the following error in the logs which was causing the Bitcoin node not to start:
Unable to parse settings file /data/.bitcoin/settings.json

Deleting settings.json using the following command after SSHing in the system and restarting the Bitcoin node fixed the problem:
rm ~/umbrel/app-data/bitcoin/data/bitcoin/settings.json

1 Like