Bitcoin core 24.0, how to enable "mempoolfullrbf"?

Hello Everyone,

I noticed Bitcoin core had an update today to 24.0. I have updated the bitcoin app within umbrel. Within the release note’s of Bitcoin core 24.0, I noticed the mempoolfullrbf is a new feature. How would one enable it within the bitcoin app in umbrel?


1 Like

By default this new Replace-By-Fee feature is flagged as off, to turn it on I believe you can now just add this line to your bitcoin.conf file:


After version 0.5 the bitcoin.conf file actually doesn’t exist by default anymore, the default options are now set using command line parameters. However, you can still create and edit bitcoin.conf and add custom lines to it. The new path is shown here, and this command allows you to add new lines:
sudo nano ~/umbrel/app-data/bitcoin/data/bitcoin/bitcoin.conf

After you’ve added your new line(s) you can CTRL+X to exit, then Y to save, and then enter to skip renaming file.

Then you’ll need to restart Bitcoin for the change to take effect:
~/umbrel/scripts/app restart bitcoin

You shouldn’t have to but you may also restart your node via System > Restart or sudo reboot to restart Bitcoin

As a disclaimer just in regards to the much discussed pros and cons on this feature and as mentioned in their post:
Contributors to this project strongly recommend that merchants and services not accept unconfirmed transactions as final, and if they insist on doing so, to take the appropriate steps to ensure they have some recourse or plan for when their assumptions do not hold.


Thank you very much for your detailed reply! I am fairly new on umbrel, how would one proceed to add the line to the bitcoin.conf file? Do I need to download a terminal app or file explorer?

If you’re on Windows you can load up command prompt or powershell, or just open Terminal on Mac(from a computer on the same network as your Umbrel) then SSH in via
ssh umbrel@umbrel.local

Then you can execute the command on your Umbrel to create and edit the bitcoin.conf file:
sudo nano ~/umbrel/app-data/bitcoin/data/bitcoin/bitcoin.conf

Then for this you type in the line:

Then CTRL+X to exit, Y to save it, hit Enter to proceed when it asks you to rename it to skip and proceed

~/umbrel/scripts/app restart bitcoin
As well should restart Bitcoin for the change to take effect.

Hope that clears it up!


Very much appreciated, that definitely answer’s my question!

1 Like

All Bitcoin node operators should seriously consider switching mempoolfullrbf on.

As noted by Peter Todd

Full-RBF is in our interests because 1) zeroconf attackers have incentives to attack the entire P2P network, as well as miners, to pull off their double spends. 2) zeroconf “risk management” services work by Sybil attacking the P2P network to measure propagation.

Both are bad.

1 Like

Great post, thanks. WIll activate this and also increase the maxmempool. Question: how can I check the currently active setting? So verify that the updated settings worked?

I have the problem, that after the command ssh umbrel@umbrel.local my Password is needed, but I cant type anything in this window

Hey @Opal , when typing your password it may look misleading while you’re typing nothing shows up, but it is registering you typing your password. Just try typing it and hit enter, hope that helps.

and @StateSpace, this command should output a list of all your channels and your fee policies to confirm. It will also give you a summary of how many fees you have earned routing per day, week and month:
~/umbrel/scripts/app compose lightning exec lnd lncli feereport

1 Like

Thanks but that not at all what I was asking. I wondered how to confirm the changed maxmempool setting worked. But I can se it changed in the mempool space app hosted on the node so it worked.

Thanks, but when I try to save overwriting, I get:

Error writing /umbrel/app-data/bitcoin/data/bitcoin/bitcoin.conf: No such file or directory