Bad Gateway Error 502 after reboot via settings menu

I have the issue that although my Umbrel seems to be running, i cant connect to its interface.

I have installed:

  • Bitcoin Node
  • Electrum Server
  • Tailscale
  • Nextcloud
  • Nostr Private Relay
    On a Raspberry Pi 4, 8GB RAM and a 4TB disk.

Everything was setup and running smoothly - on my Windows computer i had Electrum Wallet connected to the Electrum Server which runs on my Umbrel.

So today i suddenly had the issue that my Electrum Wallet was no longer able to connect to the Server on Umbrel. Started troubleshooting, checked if the issue was on my computer by trying to connect my Electrum Wallet to my friends Electrum Server which has almost an identical setup (only difference is that he does not run Nostr Relay on his Umbrel). This worked. Another weird fact was that on my phone, with green wallet i was able to connect to my Electrum Server on my Umbrel. Good old fashioned me (being an IT guy) thought well, a reboot is always good - but oh my was I wrong: I initiated the reboot via the settings menu. The rebooting window was open for like 15 minutes without changing. So i thought that maybe it has already finished rebooting and just didnt reload the page. I tried accessing Umbrel, and got a 502 Bad Gateway error (nginx/1.17.8). Weird fact is that it is up and running (sort of) as i am able to connect to it via SSH and Tailscale. Nextcloud is working as well, as i can connect my Nextcloud Clients to it and open the Dashboard which runs on Umbrel.

But i still cannot connect to Umbrels interface, always getting the 502 Error (Local, Tor and via Tailscale). Anybody had this issue as well and was able to resolve it? Would kinda suck bad if i had to stomp that thing and set up everything from scratch.

Any help would be highly appreciated!

Wanted to check nginx’ error logs - but I cannot find it. Where is it located? in my nginx.conf i see this line

error_log /dev/stdout info;

but I don’t get where i should look for a error log, as stdout is not a folder which i can access…

I also tried to find out the status of my nginx, without much success either:

umbrel@umbrel:~ $ sudo systemctl status nginx
Unit nginx.service could not be found.
umbrel@umbrel:~ $ sudo service nginx restart
Failed to restart nginx.service: Unit nginx.service not found.

Sounds like the first issue may have a local networking problem, but we will need to resolve these other issues first.

Firstly, after SSHing back into your Umbrel, can you please run the following sudo ~/umbrel/scripts/debug and share it’s output here (you can use to share if that’s easier).
From there, I would recommend rebooting again and letting it run through the whole process if you haven’t already sudo reboot

After you share the logs we’ll see if we can find anything more specific to address

Hi smolgrrr,
Thanks for the headsup. The debug log is here:
also just did the sudo reboot (again) … will let u know about the outcome.

The reboot is done, the situation i face now is the same as before:
502 Bad Gateway (nginx/1.17.8)

Yet Nextcloud Clients are connected and i can ssh into the umbrel via Tailscale.

Meanwhile I re-flashed the sd-card with umbrel os, issue with 502 error persists.

Did this get resolved? Am having the same issue, have reflashed, restarted etc. I can SSH in to check that it’s ok but that’s it, no web interface by umbrel.local or the static IP address, since a family member unplugged it once by accident. Not great!! Need to get to my funds.

My debug log: umbrel debug -