502 Bad Gateway


Im getting the following error when trying to create an invoice and start a new Lightning channel:

502 Bad Gateway

502 Bad Gateway



More details:

  • Device - MacBook Pro laptop macOS Big Sur Version 11.5
  • Umbrel Version: 0.3.14
  • Blockchained fully synchronized
  • Connected through wifi

I get the same. Latest version at this date.

Set a static IP for your node
Add that IP into your Mac hosts file
More details here

But I did not have this issue before and had no static IP.

Everything have start to happen.
Assigning a static IP to your node is not “fixing an issue” but improving your use of your node.
The fact that didn’t happen until now is that your DHCP IP assigned by your router worked until a point when was reset. So your local PC from where you accessed your node, “forgot” or couldn’t find that IP anymore.
This is how networks works. Today you learned something new :slight_smile:

1 Like

Ok thank you. Before I continue to do that Id like to understand abit more. First of all, I dont have any issue connecting to my Umbrel, I only today had my first experience not beeing able to do a lighting transaction with the channel I have opened with Bitrefill. You still think this issue is due to non fixed IP adress?

Seccondly, in my earlier Umbrel installation set up that I had to scrap due to many issues I had set upa Pi-hole with recursive DNS and Unbound https://docs.pi-hole.net/guides/dns/unbound/

Do you think its a good choice to set this up again? I was considering setting it up using another instance of Umbrel on my network just to keep my Lighting Umbrel as clean as possible.

What do you think about all that? Thank you.

I don’t use Pi-hole. Is a waste of time for me.
I have other simple solutions for a clean browsing.

1 Like

OK got ya. So I did option Option B - setup a fix IP in your RPi settings. But something went wrong, now I can not access the PI via SSH and its not showing up in Angry IP scanner anymore.

First it was all fine after changing and saving the conf file but when I scanned the IPs I saw the static IP number I had set was not actually not the number showing for the Umbrel. So I did a reboot from withing the Umbrel UI. After that I never got back in to it.

Have any Idea what happened here?


Do you think flashing the SD card again with the latest version of Umbrel would reset the dhcpcd.conf file ?

So I did flash the SD card with latest version and that reset everthying.

After that I retried changing the dhcpcd.conf again and then checked the IP in Angry IP scanner after restarting the network like so; sudo /etc/init.d/networking restart

But the IP I see there is not the static IP i set in the conf file. Have not rebooted the PI yet. Im kind of lost here and might revert to option A.


Happytimes! Rebooting after changing the dhcpcd.conf file it all worked. I thried makeing a payment and it works. Thanks alot for your help. I learned alot.

Maybe adding that you need to reboot your PI to see the changes in the instructions would be good.