Are people using a cooling mechanism?

I followed you in settling up my fan in all your steps of your 22 May post. After the reboot, fan didn’t work and PuTTY was not up anymore. Could access umbrel.local and IP address was not given by IP scanner. After a cold start of my node, I wasn’t able to find my node with an IP scanner.
I couldn’t finish your next steps when reboot doesn’t work. Can you help me further here. You probably need to dig in some old info. I’m sorry

Regards, JW

@BitView – I was looking at this thread for my May 22nd post, but couldn’t find it? May you point me to it – what is your enclosure model as well?


Will come back to it tomorrow. Busy evening with conf.calls. Excuse me.

I have just installed a cooling fan after raspberry pi4GB was running at around 70-80c, the standard plastic starter kit case that raspberry pi came with wasn’t great which contributed to the heat I believe. Make sure that you shut down raspberry pi through umbrel site first before disconnecting it from the power source to install the fan.

This is the fan & case I bought & search for any standard install video for raspberry pi cooling fan & heat sinks.

Raspberry Pi Case Black Aluminium Case with Mount, Heatsinks and Cooling Fan for Raspberry Pi 4

Hi good morning @DHD. The post I mentioned was started on May 22 and your feed to it was this: Are people using a cooling mechanism?
With SSH, I used PuTTY, to upload ‘your’ script into my node. Configuration of my node is: RPI4 8GB, expansion board is a Geekworm RPi 4 SATA X825 V2.0, and the Fan is a Geekworm RPi 4B/3B+/3B X735 V2.5 Power Management with Safe Shutdown & PMW Cooling Fan. I do not like to upload a safe shutdown. I just like the Fan to run and I like to variate its speed.
Current problem after uploading the script and the reboot; my node is not visible anymore, even if I use a IP scanner. I couldn’t execute your script to follow when a reboot doesn’t work.

Hope this helps. If not, please let me know,

Regards, JW

As another approach I sat my pi & ssd on top of my xiaomi air purifier. It costs cents to run, is silent and keeps the ssd cool as well. Typically around 38c.

@BitView What is your Raspberry Pi’s power LED status? Is it steady red, dim red, or blinking red? I was looking at the Geekworm wiki, and saw this: “When use X735 with X825, …, please power via X735.” So you need to plug in the power on the fan (the X735) itself, not the SATA board (X825). Here’s the Geekworm wiki page describing the setup:

This is getting a little complicated for me, as I don’t have the same setup as you, but I’ll try my best to troubleshoot the issue.

@DHD My power is connedted via the X735 board. Both LED were steady red but I switched of my node. I understand your troubleshooting issue. I try to troubleshoot alongside with you, as best as I can.
This evening I will give it another shot.
Thanks for your help.

@DHD Good morning. I did some research, which, actually didn’t take that long. A cold restart of my node mad the SSD blue LED blinking, the right LED continuously was steady red and the left was blinking yellow. After about 2 minutes, the right LED was continuously red and the SSD LED was continuously blue. Than, nothing happens anymore and the node is not traceable with an IP scanner.

Is it an option to completely restart and follow all procedures again, also SF flashing on microSD card?


@BitView Yes, that sounds like the micro SD card got corrupted, so reflash the micro SD card only, and it should work again. It will remove the script that you put in, so you might need to SSH into your node and install it again. You WILL get alerted about “WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!” and you need to follow the instructions on the screen on how to remove that line from your known hosts file.

Hi @DHD,
I got my node working again with Umbrel but the fan doesn’t run. Haha. I conected Geekworm because it could be a DOA (death on arrival). I keep on trying and inform you along the way. If you have a new script for running a Geekworm fan only, please let me know.


@BitView Do you have any heatsinks on the board itself before you installed the fan? That will prevent the fan from working, like another person in this thread found out.

No I haven’t thanks. Geekworm mailed me to install the Raspbian OS instead of the Umbrel download incl. OS. Do you know if a separately installed Raspbian OS functions along the Umbrel download?

@BitView Umbrel is based off Raspbian OS. I don’t think the guys at Geekworm know what they’re talking about. We just need to adapt the script to use the ‘umbrel’ username instead of the ‘pi’ username, that’s all.

My thoughts @DHD . Thanks. Yesterday I tried this script and nothing happens. You mentioned this in this thread before. I asked Geekworm what could be the case but they don’t have a clue.

Afterburner @DHD. I tried this nice piece of script written by you. Are people using a cooling mechanism?
I will probably make a mistake. Fan doesn’t start running. How to erase all script and start all over again?


I tried everything but my fan won’t run. Today I SSH’ed your code (see below) but fan doesn’t run. Umbrel part does work but my temperature rises quit quickly.
I don’t know if you or others of Umbrel can help. Sofar thanks a lot and if you’ve got new ideas, let me know.

Kind regards, BitView

sudo apt update && sudo apt upgrade -y
sudo apt install pigpio python-pigpio python-smbus python3-pigpio wiringpi git -y
git clone
cd x-c1
sudo chmod +x *.sh
sudo bash
sudo reboot

When it reboots, then the fan should start running, if not – then it needs the crontab job to be added:
sudo select-editor
Choose nano, I’m assuming it is 1
sudo crontab -e
Use the arrow keys on your keyboard to scroll down all the way to the bottom
If you have any other crontab jobs that you put in, you can remove them.
Copy and paste the line below on the very bottom of the crontab:
@reboot python /home/umbrel/x-c1/

Save and exit by pressing CTRL+O (letter o, not zero) then press CTRL+X
then reboot it once again (sudo reboot), it should start running the fan.

I really hope this works, as after reading that set of instructions I can see why it’s confusing.

Hey @DHD. Just to let you know, my fan runs…finally. very happy and thanks for your help.

1 Like

@BitView That’s awesome, I’m glad to help.

So this week my Geekworm NASPI PWM fan (running continuously, as I cut the yellow wire) started really buzzing loudly. The Mrs. made me move the Umbrel to another room, as it was really annoying her.

I blew into it through the fan opening on top, and a ton of dust fuzzies started coming out from all of the vent openings on the case. I vacuumed around all of the vents, and blew a bunch more of the dust fuzzies out, and eventually got the fan to go back to a relatively quiet mode, but this got me back to looking at alternative cases with passive and/or active cooling. (I think I need some sort of filter over the fan intake opening on this Geekworm case, too.)

I am planning on standing up several more Umbrels with big SSDs, to put in other locations for redundancy, and to hopefully use as Nextcloud servers to create my own Dropbox alternative. I stumbled upon the Ice Tower cooler, which seems pretty interesting and which can run with an attached fan, a nearby fan (on the case wall), or no fan at all.

That in turn led me to cases that can hold an RPi + SSD + ice tower, which led me to this from Michael Klements in Australia. I like the idea of the connected mini-OLED display, which would save me from having to log into the Umbrel every so often to make sure it is connected and working. Klements sells kits for his case on etsy, shipped from Australia, but there’s a competing product on Amazon from GeeekPi that I could get sooner.

I am waiting on 2-3 more RPi 4Bs at the moment, but would like to get the cases and SSDs and SD cards ready to go in the meantime. Does anyone have any experience with either of these mini-tower cases with Ice Tower cooling (active or passive)? How about any alternatives to Klements or GeeekPi? I’d be really interested in a tower type configuration with a metal case, but I haven’t seen any that incorporate a spot for the OLED display. Any help greatly appreciated.

1 Like