Anyone Have A Working RPi 5 with USB3 based SSD?

I have been unable to build a stable, working system using UmbrelOS 1.0.x, and I’m curious if anyone has successfully built one?

If so can you please post the specific hardware you’re using.

My set up is…

Processor: RPi 5 with 8 GB RAM.
Micro SD Card: SanDisk Extreme microSDXC 64gb A2 card (ASIN B07FCMBLV6).
USB3 SSD: Crucial P3 Plus 2TB PCIe Gen4 3D NAND NVMe m.2 SSD (ASIN B0B25ML2FH) mounted in an SSK M.2 NVMe SSD enclosure (USB 3.2 Gen 2 to NVMe PCI-e) (ASIN B07MNFH1PX).

1 Like

Your NVME is the same as mine, Crucial P3 Plus 2tb, mounted in an enclosure and connected via USB 3.0. The case I’m using is an Argon One V3 for the RPi5.

I’ll check out the specs on your enclosure…I suspect that my enclosure might be the culprit. It might be a speed issue and the UmbrelOS kernel can’t keep up with the speed. When I reformatted everything and went back to Bookworm I configured the kernel to use Gen 3 speeds and the NVMe drive works very fast. But it the kernel in UmbrelOS is using older drives there may be a timing issue that causes the USB3 based device to drop out. Just don’t know…

It’s the USB 3 enclosure I’m worried about, not the RPi 5 case. Which one USB3 to NVMe did you get?

I have tried this one from Amazon:

with a Lexar NM620 2TB SSD, M.2 2280 PCIe Gen3x4 NVMe 1.4.

Unfortunately, it doesn’t work with that either. I have tried it several times.

Now I have a SANDISK Extreme Portable and it works.

I hope I can transfer everything to the NVMe without any problems.

I bought this one, which didn’t work either…

Right now I have no idea when they’ll push 1.1, how stable it will be, or if it will support NVMe boot (No Micro SD card). I just went back to Bookworm and booting from NVMe (which is VERY fast compared to micro SD slot), and installed Bitcoin Core directly. It took about 18 hours for the block chain to download and sync, but it’s running just fine (low CPU usage, reasonable network consumption) so I will have to be completely convinced of stability and usability to try UmbrelOS 1.1. And I don’t feel like re-downloading the entire blockchain again, so if there’s not a decent way to move what I have over, that’s another hurdle…

I really fell for the fancy marketing BS for 1.0, and assumed that the “production release” would be an actual solution that actually supported RPi 5 fully. Sadly, that isn’t the case. No timing info on when NVMe support will be released. No actual online docs on the OS/environment that end users can work with. No theory of operation or architectural overview so users can understand how it’s put together so they can trouble shoot. No real access to the underlying OS (via terminal) or understanding on how to install or build things, or do break fix. I guess they just expect users to use the “store”, and post questions to the community. That seems like a real tough way to release a software “environment” and is doing nothing but creating all kinds of “feedback” that I’m sure they don’t need right now. As a software developer/system manager for over 40 years, I’d hate to be the developer who is also the help desk and troubleshooter, and who is developing and doing break fix at the same time. Oh well…

I can understand your anger, but don’t be so harsh.

Unfortunately, that’s the reality. We are increasingly becoming beta testers.
But in this case, it’s free to use, so I can live with it.

I had the same issue with a satellite receiver that cost €400. I was very annoyed.

I read in a thread that the NVMe update won’t be available until the end of April at the earliest.

I tried Citadel before that. It was exactly the same. But that was also too user-unfriendly for me, as I have no idea about Linux.

Everything will be fine. Especially with Bitcoin.

Harsh? If I’m being that then I apologize. I don’t think that pointing out legitimate issues is particularly harsh, but what do I know…it’s certainly not my intent. I would much prefer to buy the Umbrel team a beer and have a good conversation…

I actually think I’m just discussing facts, simple facts. And I’m not angry at all, just disappointed. Simple transparency would have resolved this issue. I pity the person that finds the new UmbrelOS release page, happily downloads and tries to install, and then finds out no NVMe, and flaky USB 3 enclose support.

As I just posted on a different response to a different thread…just be transparent about what is actually supported. And I really do hope they’re able to resolve the issues; I’m sure it’s not fun to do hard development and end user support and break fix, all at the same time…

1 Like

That was just my personal impression, which doesn’t have to be right. I didn’t want to offend you.

I can understand your disappointment. I’m frustrated too, as I’ve been trying to set up a full node since the beginning of the year.

But at the end of the day, we get all this for free and so I have a lot of respect for the job the girls and boys are doing.

Let’s all have a few beers together.

I think this community is great, and above all the respectful way we treat each other.

I’m going to open another beer. Cheers!

Cheers! No offense taken at all! I’ll crack open a beer as well!

It’s all good, we understand each other! Cheers.

I agree
I’m gonna sit back, tip a cold one, and wait for a fix.