An estimate when an umbrelOS compatible with Raspberry Pi 5 will be released, please?

Dear @lukechilds, I assume that Umbrel team already received Raspberry Pi 5 test units for a while now… Could you kindly provide an estimate when an umbrelOS compatible with Raspberry Pi 5 will be released, please?
Days? or weeks?!

The present release 0.5.4 umbrelOS (compatible with Raspberry Pi 4) will NOT work on Raspberry Pi 5, correct?

cc: @nmfretz


True, I feel umbrel is slow on development, I would love it if they had a beta branch or a dev branch to see new features pushed, or the development to be accelerated.

Correct, it does not work.
In essence I asked the same thing weeks ago and there has been no response in that thread.

That’s quite disappointing to hear that guys. Thanks for confirming.

Unfortunately we still haven’t received our test Raspberry Pi 5 units, but please be assured will hope to have this new image ready ASAP


Hi guys, is there any update on this issue? Did you receive your pi5 @smolgrrr ?
I would love to start using my pi5 for Umbrel but right now it’s just sitting here, staring me in the face every day :smiling_face_with_tear: thanks!

An alternative way to use Umbrel on a Raspberry Pi 5 AFTER setting up Debian Bookworm 64-bit ARM (Arch64):

curl -L | bash

It just requires a bit more of a manual set-up.

1 Like

I was able to install it on a micro SD card and run it in the Pi 5 (blockchain was downloading) but since the full block download is over 500GB the micro card won’t work so I tried using a 2TB external drive, installing the Debian etc. on it but when I ran the curl -L | bash command I got an error message: Line 1 3098 Bus error.

Maybe there is something else I should have set up in order to use the external ssd?

Ive just done this on a bookworm based install
Using a single ssd drive. Electrs is sync at the moment.

Its heavier usage compare to the umbrelos verion

But I will attempt to trim services etc down next:,