Updated correctly to umbrelos1.1 but the Dashboard disappeared after restart

Hi, after some difficulties I managed to update my Umbrel to version 1.1.
I was able to access the Dashboard at ‘mymachine.local’, restore all my apps, and everything seemed fine for a day.
I use a virtual machine on Hyper-V and I needed to restart the host machine, so, through the Dashboard, I shut down the Umbrel virtual machine, waiting for it to shut down as requested in the browser.
When I turned Umbrel back on, I could no longer access the Dashboard. I can access the virtual machine via the terminal, I checked that the umbrel.service is running, I checked the IP, but no access via the browser.
Any suggestion? I already have a week in this fight to restore my Umbrel, I had to do a lot of research as the update was not as simple as the procedure looked like. Now this one. I have no more ideas, so I had to come here and ask for the first time.

Had the same problem maybe - the IP of Umbrel no longer bring something up.

Here is my experience. I just name it ‘homepage’, it’s not in virtual machine, rather standalone RPi but read it and try if services (mempool or what not you expecting to have) Umbrel does provide running. In my case all working but no homepage/dashboard as well.

Tried access the dashboard putting a /settings after the IP but didn’t work. I tested if the tailscale app is running but it is disconnected.
Tried to run the command umbreld and this erros comes:

umbrel@dr-vm:~$ umbrel@dr-vm:~$ umbreld client apps.list.query
return process.dlopen(module, path.toNamespacedPath(filename));

Error: libnode.so.108: cannot open shared object file: No such file or directory
at Module._extensions…node (node:internal/modules/cjs/loader:1454:18)
at Module.load (node:internal/modules/cjs/loader:1208:32)
at Module._load (node:internal/modules/cjs/loader:1024:12)
at Module.require (node:internal/modules/cjs/loader:1233:19)
at require (node:internal/modules/helpers:179:18)
at bindings (/usr/local/lib/node_modules/umbreld/node_modules/bindings/bindings.js:112:48)
at Object. (/usr/local/lib/node_modules/umbreld/node_modules/drivelist/lib/index.ts:55:27)
at Module._compile (node:internal/modules/cjs/loader:1358:14)
at Object.S (/usr/local/lib/node_modules/umbreld/node_modules/tsx/dist/cjs/index.cjs:1:1292)
at Module.load (node:internal/modules/cjs/loader:1208:32) {

Node.js v20.13.1

It seems that umbrel did not started. Is it possible to start with the script sudo ./scripts/start, as the old version? It says that docker.compose is needed.

I am having exactly the same issue, just not with VM but with my Mac Mini. (just updgraded to umbrel 1.1.2 yesterday)

I can SSH into umbrel, but I cannot access the dashboard via web browser nor am I able to access it via tailscale. It also happened after shutdown and reboot.

Any ideas how to solve this?

I was able to solve the issue by reinstalling (“fake” updating) umbrel by

sudo mender install https://download.umbrel.com/release/1.1.2/umbrelos-amd64.update && sudo reboot

Maybe this could help?

Hello Django, I tried to reinstall but some error ocurred with mender command.

INFO[0000] Loaded configuration file: /var/lib/mender/mender.conf
INFO[0000] ‘UpdateControlMapExpirationTimeSeconds’ is not set in the Mender configuration file. Falling back to the default of 2*UpdatePollIntervalSeconds
INFO[0000] ‘UpdateControlMapBootExpirationTimeSeconds’ is not set in the Mender configuration file. Falling bac k to the default of 600 seconds
WARN[0000] No server URL(s) specified in mender configuration.
WARN[0000] Server entry 1 has no associated server URL.
INFO[0000] Mender running on partition: /dev/sda2
INFO[0000] Performing remote update from: [https://download.umbrel.com/release/1.1.2/umbrelos-amd64.update].
Installing Artifact of size 1382419968…
INFO[0001] No public key was provided for authenticating the artifact
WARN[0001] Returning artifact name from /etc/mender/artifact_info file. This is a fallback, in case the informa tion can not be retrieved from the database, and is only expected when an update has never been installed befor e.
ERRO[0001] could not get the current Artifact name
ERRO[0001] open /etc/mender/artifact_info: no such file or directory
ERRO[0001] open /etc/mender/artifact_info: no such file or directory

Have you had this error too? What could it be? I will search another way to reinstall umbrel.


If I remember correctly, I saw only those INFO and WARN lines. No errors.

However, you could try fixing your error by creating the artifact_info file:

cd /etc/mender
sudo touch artifact_info
sudo nano artifact_info

Then paste there:


save by CTRL+X, hit y and enter.

Then try reinstalling again.

Let me know if this helps.

Thanks Django.
After two reinstalling, lots of search at google, chatgpt and specially your help, it worked!
Now I can access the Dashboard again and my apps are syncing.
I will never restart umbrel from now on… lol

1 Like

I’m glad I could help. :slightly_smiling_face:

It actually happened to me again today. It does not happen every reboot, just from time to time. There obviously is some issue that will have to be fixed in future versions of umbrelOS. Fortunatelly, update/reinstall process is quite simple with 1.x.x and mender.

1 Like

Also, next time this happens, I am gonna try start the main umbreld service via sudo systemctl start umbrel first. This could also help.