Umbrel 1.1.2 (x86) failes to start correctly after shutdown

Hi, two days ago I upgraded my Ubuntu server (running on Mac mini late 2012) from umbrel 0.5.4 to umbrel 1.1.2. I managed to migrate all the data and everything worked fine for a few hours.

However, I needed to move the Mac mini to another part of the room, so I shut it down via the web interface and unplugged the power cord after the shutdown was complete. After moving the Mac around I tried to turn it back on expecting it to boot umbrel normally and access it via the web browser, however, it failed. The base system boots up, I can get into it via SSH, however I am not able to access the dashboard nor any of the apps. LN channels are down, the whole umbrel is down.

I tried rebooting several times but that did not help. I have no idea what to do now. Any ideas?

Is there at least any way how to rescue the data and move it to a fresh install?
(something similar to the migration process used while upgrading from 0.5.4 to 1.1.2)

OK, I was able to fix this by reinstalling umbrel by

sudo mender install https://download.umbrel.com/release/1.1.2/umbrelos-amd64.update && sudo reboot

Now I can access my dashboard again and all the apps are up and running!