Unable to connect to peer, server is still in the process of starting

I am trying to open my first channel with this node and am getting this error in both Lightning node: “Unable to connect to peer, server is still in the process of starting”

Ride the lightning error when opening channel: “Server is still in the process of starting”

This is after my pi has been online for more than a week. So I have since shutdown, and restarted to see if that helps, but it does not.

I can open both the bitcoin node app and the lightning node app in umbrel and everything looks OK, I even have funds waiting in the lightning app to open channels with, but I am stuck.

Umbrel logs are here: https://pastebin.com/bKPDTE1z

Please can someone let me know if something is blatantly wrong as I am having so many problems and struggling to get things to work out of the box.

Looks like you are out of memory. Try deleting some apps you don’t necessarily need now and try again.

I only have a few apps installed and want to use them all. Where did you see that it is out of memory in the logs? What is normal amount of apps for a raspberry pi 4?
I tried again this morning, still same error saying the server is starting, but its been up since yesterday

I just noticed it says free: 126M. But you have 8GB, that should be more than enough for the apps you’re running… I would try to remove apps like mempool and see if it helps just to rule out the memory issue.

I removed mempool, but still have the same error.

From the logs:

Screenshot 2022-10-18 at 13-56-24 Umbrel

I am about to give up on umbrel to be honest…so frustrating

I’ve got this exact same issue. Running latest OS 0.5.2 and LND 0.15.3-beta. Has been working well as a lightning node for many months, and now useless. Please can someone from Umbrel figure this out? Just get error in the logs:

2022-10-29 20:18:59.527 [ERR] RPCS: [/lnrpc.Lightning/ConnectPeer]: server is still in the process of starting

Ah, actually this started working again for me after an hour or so. I didn’t do anything.

I also updated to the latest version of Umbrel, and I still have exactly the same issue. I cannot open any channels, error still says “Server is still in the process of starting”.

I see my LND version is: 0.15.1-beta

Does anyone know how to update this? Maybe this is causing the problem I am having…anyone?

Hello! Did you solved it? I had to restore from the backup file and the transactions were not submitted due to this. I can’t recover my funds as all the channels are pending to be closed and I can’t add any peer due to this.

Running the following command has now finally allowed me to see the update button, and update LND to the latest version:

sudo rm -rf ~/umbrel/repos/https—github-com-getumbrel-umbrel-apps-git

Once that is done, I ran:

sudo ~/umbrel/scripts/repo update.

This time I get no more errors. After rebooting I am finally able to perform updates in the GUI.