Umbrel timezone?

Does umbrel have a way to setup a timezone? I am having some issues with lncli that I believe are related to timezone.

For some reason “lncli fwdinghistory” shows my routings with a 6 hour delay. Both LNDg and RTL show the forwardings correctly, but when running from terminal “lncli fwdinghistory” I can only see routings with a 6 hour delay.
I think it has something to do with the server timezone, umbrel timezone or lnd timezone.

Now, the server time is UTC and LND log file also logs in UTC. However, I changed in the past the server time from EEST to UTC and vice versa. Not sure if this caused the problem.

What is strange is that both LNDg and RTL shows real time data, I thought they also use lncli, so how do they get the data without the delay?

What should I do? Any help is appreciated.

You must map timezone and localtime from host to the container. Edit the docker-compose file for lnd. In v0.5.0 the path to the file is ~/umbrel/app-data/lightning/docker-compose.yml and add the following two lines under lnd service:

- /etc/timezone:/etc/timezone:ro
- /etc/localtime:/etc/localtime:ro

docker-compose is strict with syntax so be careful with spaces, it should look exactly like this:

  - /etc/timezone:/etc/timezone:ro
  - /etc/localtime:/etc/localtime:ro
  - "${APP_LIGHTNING_NODE_DATA_DIR}:/data/.lnd"
1 Like

Thanks. I am using umbrel version 0.14.8. I added to /home/umbrel/docker-compose.yml under lnd the volumes. Then restarted umbrel. Now, the delay is even bigger: 18 hours! What can be wrong?

Thank you.

run sudo raspi-config go to localization settings > timezone > set your timezone

I am not running umbrel on a raspi. I run it on a debian.
Sat 11 Jun 2022 06:11:41 PM UTC
The date and time there is correct, and it is UTC.

It’s UTC so the docker container is using UTC now. run timedatectl list-timezones to find the exact timezone to use. For me it’s America/Los_Angeles.

To set your timezone (replace America/Los_Angeles with your timezone)

sudo timedatectl set-timezone America/Los_Angeles
sudo reboot