Screwed up! node is dead!


I need help!!!

I screwed up while trying to upgrade SSD to 3 tb, but it failed and end up corrupting my node (it is not working).

The node was upgraded to the latest umbrel version recently, and I have the 24 words and the backup that we usually get at the time of upgrade.

Please help!

1 Like

You can try option 7 or 8

And next time when you want to upgrade a disk, just use Acronis Image cloning, disk to disk clone.

1 Like

Thank you, @DarthCoin. I started with option 1. The node is up and the blockchain started syncing. However, the LND steps didn’t seem to work. Perhaps, I will need a backup from “devs.” Please advise. I had a lot of funds on LND, the only backup I took was at the time of recent upgrade that umbrel offers under settings.

So you don’t have anymore the old drive? Is formatted?
Read again my guide, it is mention where you can locate the copy of the backup on the old drive.

Yeah, the old drive is corrupted. But I have the my-umbrel-channels.backup that I took on 2022/03/09 while upgrading umbrel to the latest release. I used it to complete recommended STEP1 and STEP2. (Please refer to the attached screenshot.)


At the moment, the node is syncing… bitcoin wallet is showing the funds as before, but LND is weird… $0 but it keeps changing the peer channels in LND.

I hope I didn’t screw it again!!! :frowning:
I had a lot of funds in the LND channels. :frowning:

Is OK, those peers are NOT your channel peers, are just random.
Install Thunderhub and/or RTL to see the closing channels.
Also install the Lightning shell app, where you have access to cli commands and check the status of pending close channels

@DarthCoin, thank you so much for your response – much appreciated.

Just installed the Lightning Shell app. What commands can I run to view closing channels?

I also installed the ThunderHub app… It shows nothing. :frowning:

Shall I re-do STEP 1 and STEP2 to copy and restore the channel.backup file?

Is there another channel.backup file that I could get from Umbrel (even though I took a backup a day before?)?

I noticed the new LND id is the same as before the crash but different after “@” (lndnodeid@xxxx). That is, say, before the crash lnd id was: abc1234@xyz, and after the crash, it is abc1234@pqr (abc1234 part is same).


Did you read my Umbrel troubleshooting manual? In there are all kind of command, including how to check the closing channels. You can find it in Guides section of this forum.

Thank you, @DarthCoin. I have been going through the guide. Here some of the output from Lightning Shell commands. I am unsure of my next steps. Shall I go ahead and repeat STEP 1 and STEP 2 for channel.backup /restore?


So you don’t have any pending channels. So all fine. What do you want more?

Okay, saw your (@DarthCoin) response to a similar question in another post advising not to do it twice, so I won’t.

But I do need help with the next steps… I had millions of sats on lnd. :sob: It would be an awful experience to lose them despite me taking backups, restoring with seed words, and trying all I could all in vain. :sob:


Maybe I am missing something. How do I know the channels are closed and the funds are in the process of being released to my wallet? (I somehow do not see any logs or evidence of it, yet.)

but is right before your eyes the answer: lncli pendingchannels is 0

That means all channels were closed and funds back to onchain.

Hmmm… Shouldn’t I see closed channels somewhere in the logs? Moreover, I haven’t received a single sat back yet (I had a few million sats liquidity locked in those channels).

Again, thank you so much for your (@DarthCoin) guidance and education — much appreciated!

Yes, but if you restarted, was wiped the logs.
Try again the restore procedure

@DarthCoin, by “try again the restore procedure,” are you referring to the step 1 and step 2 for restoring channel.backup file?

step 1: copy channel.backup from my local to umbrel (scp command)

step 2: restorechanbackup (the full command per the guide)

Please confirm. Thank you!

yes, maybe wasn’t triggered correctly first time. I don’t know what you did.

1 Like

@DarthCoin, it worked! THANK YOU!!! :pray:

OMG! All sats came back in a minute.

For others who might be looking for some clarification, this is what I did (screenshot attached):

This time, I ran these commands from Windows PowerShell (Run as Administrator) instead of Command Prompt.

Step 1: scp C:\channel.backup umbrel@umbrel.local:/home/umbrel/umbrel/lnd/channel.backup

(it asks for umbrel pwd)

Step 2: ssh umbrel@umbrel.local

(it asks again for umbrel pwd)

Step 3: cd ~/umbrel && ./bin/lncli restorechanbackup --multi_file /data/.lnd/channel.backup

1 Like