Rebalancing command LNCLI?

I want to run the LNCLI rebalancing command on The instructions say:

Create an invoice to get the [PAYMENT_ADDR] and [R_HASH] values:
lncli addinvoice --amt 2000000

But that didn’t work. Does anyone know if I have to add something before that line since I’m on Umbrel, i.e. docker etc? Thanks.

You are running the command in the wrong folder.
As it is explained in the Umbrel troubleshooting manual the command is:
cd ~/umbrel/bin
sudo docker exec lnd lncli

1 Like

OK, thanks! So just to clarify, I first enter “cd ~/umbrel/bin” and hit return, then enter “sudo docker exec lnd lncli”, and then finally I run the “lncli addinvoice --amt 2000000” command?

Update: It seemed to work if I enter “sudo docker exec lnd lncli addinvoice --amt 2000000”.

The first command worked but the 2nd one not. The instructions for the 2nd command says: “lncli buildroute --amt 1000000 --hops…”. So I tried to use “sudo docker exec lnd lncli buildroute --amt 1000000 --hops…”. Can someone let me know if that’s correct or not? When I run it, I first get an error but then it looks like it did something anyway. This is what I get:
-bash: lncli: command not found
[lncli] rpc error: code = Unknown desc = no matching outgoing channel available for node 3 (037172d2110c4148d6ed0c2790ec8be948458022425dced6794fede834be92af36)
umbrel@umbrel:~/umbrel/bin $

yes you are doing it right. Only that destination is offline or you paste the a wrong channel id

OK, thanks! Just curious as to why it first says “-bash: lncli: command not found” before the result?

Also, I’m currently participating in 3 different swaps on And I get the same error message when I run the scripts for each of these swaps, i.e. “no matching outgoing channel available for node X”. When I look in Thunderhub, all nodes are online. Any ideas? One is a Triangle swap and two are Pentagon swaps.

You have to run the ln-cli in the bin folder
cd ~/umbrel/bin
sudo docker exec lnd lncli

That’s what I have been doing. But other people in the swaps are saying that they are getting the same error. And someone speculated that it could perhaps be because some people have updated to lnd 13.3 and some not (I have not)? Could that be what’s going on could it be something else?

Yes, many nodes are updating now, you should try that in few days until this crazyness is slowing down.
People are freaked out too easy and enter in panic mode.
Patience is important.

OK, thanks. Hopefully that’s what’s going on.

I am also having some challenges with the LNCLI

I am getting a “the input device is not a TTY” error.

I am working to rebalance channels from a swap

First step:
umbrel@umbrel:~/umbrel/bin $ sudo docker exec lnd lncli addinvoice --amt 1150000

umbrel@umbrel:~/umbrel/bin $ sudo docker exec lnd lncli buildroute --amt 1150000 --hops 02bc320249b608a53a76cf3cbd448fdd3ab8f3766f96e8649c2edc26cf03bf8277,035eb7d2253d934b51dd1cc145b6f36a9c2d953c4379f5fff9c39bb437ece525ae,03ac80331775d256eeb7438463e9cf1b986fcc77f84d9501cb52f34ab957fb6e1b,02bd173762f980267f9aa02f5db6a43c1b1f075a0f9f8425668eaa3a21f5252897,0263816bd2eedcb22690bfa623b36512f20aa134e77d247e56f15f2ab57c9fbebc | jq -r ‘(.route.hops[-1] | .mpp_record) |= {payment_addr:"[PAYMENT_ADDR]", total_amt_msat: “1150000000”}’ | lncli sendtoroute --payment_hash=[R_HASH] -

the input device is not a TTY

Are there additional flags I need to set?