NVMe SSD PCie 2TB Memory No Light

Using Western Digital WD_BLACK SSD, 2TB, NVMe, PCIe installed into a PCIe to USB C adapter. Plugged into my Windows desktop USB port. I get a light on the adapter. Windows shows this external drive properly as one would expect.

But…Plugging this into the Raspberry PI 4B card, NO LIGHT. Does not function.

Does the Raspberry PI 4B not work with power needing devices?

Hey @rwrider :wave:!
Are you using the official power source for your raspberry?
Have you plugged your SSD into a USB3.0 port?
Do you see the RaspberryPi Green & Red LEDs turning on/blinking?

I have the official power supply. I tried all USB ports including the USB3 one. Green and Red LED’s blinking.

Plugging in a Samsung 128 GB “thumb drive” worked, and let Umbrel boot up. I am now syncing up to the blockchain running Bitcoin node after hooking up a Seagate 4TB mechanical drive.

This M.2 PCIe 2TB SSD drive, mounted in an Ankmax USBC enclosure is not recognized on the Raspberry PI, but works great on other platforms. I even formatted it EXT-4 using Minitools utility.