No contact with Umbrel device

Hi there
Just received my new Umbrel home
Was very excited… now depressed as I can’t make it work !
I thought this was supposed to be easy … plug and play
Am in the UK, so first thing I had to do was order a compatible UK plug… got a recommended one from Umbrel site …all good
I have a Virgin Wifi hub … version 4
It has 4 Ethernet sockets
Plugged the Ethernet cable provided into a socket on the wifi … then into the Umbrel … and plugged power in
Umbrel lit up… and clearly was active and whirring
Tried to log on via my Chrome browser using Umbrel.local … no contact
Managed to access the router using IP address and discovered that it did not recognise any ethernet connection
Thought it might be the cable… so bought a new ethernet cable (probably not necessary)
I then connected up my PC to the router using the ethernet cable provided … it recognised my PC as a connection … so the ethernet ports on the wifi definately work
Connected up the Umbrel again … connected to my wifi using the IP address … no ethernet connection shown
I tried all the 4 ethernet sockets … with ethernet cable provided… and the one I just bought … still nothing
I admit I’m not particularly ’ techy ’ … but I can follow simple instructions !
Would be grateful for some advice as to what to try next