No button to Uninstall Apps from App Store Pi4 UmbrelOs

There is no button on AppStore / Manage App to Uninstall Apps from App Store
I am using
UmbrelOs 0.5.3-build-d6641f8

Using command line I was able to issue stop command.

~/umbrel/scripts/app ls-installed
sudo ~/umbrel/scripts/app stop tailscale

I have tried but this is also not very useful as this does not cleanly uninstall /

It seems it has not even stopped properly as well.

The new method is to right click on the icon on your home screen and choose to uninstall.

Hope this helps

Have a great rest of your weekend.
Happy Halvening

The Home Screen right click only shows the Browser Right Click menu Options. What Am I missing ? Here is the screen shot. I am using Pi 4 and it is connected with a router.

I am not sure if this detail makes any difference. I have not connected Monitor/Keyboard to the Pi4 setup. I am logging into the Umrel using another machine and using umbrel.local url and tried it using IP address based url as well with no difference.

Here is the attached screenshot of what I see.

Very odd I do the same thing as you and this is what i see when I right Click.
Perhaps try another browser

EDIT - My Bad you are on 0.5 Umbrel. In that case click on the MANAGE APPS Button there near the Bottom of your screen and center